Pepwave MAX HD4 Sprint "Obtaining IP Address" problem

Hi there,

I just got 2 Sprint Data SIM cards and they aren’t connecting to the network. It gives me “Obtaining IP Address” on both Cellular Modules.

I have checked other threads and I have upgraded firmware to the latest version, with no success.

I have changed from Auto to Custom in Network Selection, Band Selection and APN settings selection with no success.

Is there anything I am missing?
I have asked the carrier about it and they say everything is fine from their side, but everything seems fine on my side. They want me to factory restore the router. I don’t believe this would make a difference and I wouldn’t like to remake all the configuration.

Thank you for any advice in advance!

Sorry to hear about your trouble.

You should be able to download/backup the configuration file of the Max before doing the factory reset. Then you can reload the configuration back in from the file.

We often do this before firmware updates as well.


I will try to factory restore the Pepwave HD4, but this is very bizzare.

The Pepwave is trying to connect to other bands that Sprint don’t use. It is trying to connect to band 2 if I leave it on auto.

I have changed the Network Mode to Sprint and it still tries to connect to other bands that Sprint doesn’t use, like band 12.

Any suggestions?

Do you know what kind of Sprint SIM you are using? Depending on whether your device is an LTE or LTEA version effects what type of SIM is compatible. If you aren’t using a compatible SIM that may be the source of your problem.

LTE devices are compatible SIMGLW106R SIMS
LTEA devices are compatible with SIMGLW106Q SIMS

Below is a forum post discussing the different types of Sprint SIMs that should be used for Peplink products.

1 Like

Hey Calvin,

My SIM’s are the ones for LTE-A: SIMGLW106Q
The Pepwave is a MAX-HD4-LTEA-W, LTE-A
I have read that thread and it looks like the same problem. However, I was given SIMGLW106Q straight away.
I have opened a ticket with Sprint, but I think I will open it with peplink too, as it looks like this might not be a just one scenario.


Hi Calvin,

Please open a ticket with Peplink and we can make sure your cell modules are up to date.



1 Like

Hey Erich,

I updated the cellular modules 2 days ago to the latest firmware (Picture attached):

Ticket opened #9050761, Thank you!

Hey All,

Just to let you know, The SIM provider has told me that the SIM’s they provided me say that are 106Q, but the internal chip isn’t.
Just a bad batch of SIM cards. It seem’s that they got the name right but the chip wrong…

Thank you all for the replies!


Hi all,

New SIM’s arrived and they give the same problem.
I will let you know what support says.


[EDIT: Didn’t realize this thread was from last year. Leaving my response here anyway…]

Jumping in here to say that I’m experiencing the same problem. I am working with a brand new HD2 IP67 with a SIM Injector.

I was told that Sprint is the one provider with which you MUST register the SIM card to the specific IMEI number of the device, and I did do that with them.

On my Dashboard I see that the device sees the correct SIM card, showing me its IMSI, but it can never fully initialize. Just an endless repetition of:

Obtaining IP Address…
WAN failed SmartCheck

AT&T cards in the same SIM Injector connected to the same device have activated flawlessly.

I will look into the issue of needing new/different SIM cards. I am skeptical, however, as I moved a different SIM card to a BR1 Mini with an LTEA modem, calling them to pair the IMEI of course, and it worked just fine.

Would appreciate any updates on your situation.

Hey Gaffy,

I didn’t get any further than that. I changed the provider and all worked Fine.

Have you tried to put the SIM card directly in the Dome?

I think the SIM injector is still under development and some SIMs catches up in a second, others just seem to stay on Obtaining IP address.