Pepwave MAX BR1 MK2 verizon SIM PIN password error

Hi all,
I am running Model: Pepwave MAX BR1 MK2
Firmware: 8.0.0s061 build 1436
I don’t want to upgrade the firmware yet…too soon, waiting for bugs to be worked out.
I have an ATT sim in slot A and a verizon sim in slot B.
The Verizon sim only connects when I have the settings as below:

I wanted to have the Verizon sim (card B) be the failover sim so I set the settings as below:

It works fine with Sim A most of the day with a few errors:

The errors seem to only happen when the device tries to switch to SIM B. Error: “pin required or incorrect”.

I was never required to enter a PIN for sim B for setup. How do I get the failover to work without using a PIN?

Thanks for the help!

I have seen SIM Pin required (on a SIM with no PIN set) when the SIM is not seated properly. Might be worth popping it out, cleaning contacts and putting it back in.

If its one of those SIMs that you can push out the chip to make it smaller (down to nano size) stick a bit of clear tape on the back of the sim to hold it all together (this also makes it slightly thicker which helps with the contacts).

1 Like

Hello @Troy,
In addition to what @MartinLangmaid recommended:

  • Swap the SIMs with each other and see if the fault follows
  • Test the SIM in your mobile/cellular phone.

Sometimes SIM Cards do fail, we have some every year that need to get replaced (normally older SIMs or SIMs in extreme environments), the SIMs are electronic chips, and just like all electronics, they can fail from time to time.
Happy to Help,
Marcus :slight_smile:

1 Like

The sim works when I switch it manually in the cellular settings so I know it has not failed.

I tried pulling the sim, taping it as Martin suggested and re-seating it but still have the same problem.

Any other suggestions?

I was thinking of calling Verizon and setting up a pin.

@Troy, it seems like a bug of the old firmware. Please set the Network Mode to Auto to confirm it helps. If not, please upgrade to the latest firmware version.

Switching to network mode “auto” did not help.

I will upgrade the firmware and report back.