Pepwave BR1 - ProjectFi SIM

Any one on this forum tried to use Pepwave Max devices with Google’s ProjectFi? Seems like it would be a perfect application for any transit routers and we wouldn’t have to worry about any roaming issues.

Just for discussion sake…


I have just received my new BR1 mini, and have successfully connected to Project Fi, but it took some finagling.
Click the Details button on your cellular connection section
Scroll down to Cellular Settings, Network Selection radio button for Auto will probably be selected.
Click the help icon, and click to restrict to carrier, then scan.
Project F is one that showed up for me, along with Sprint, Verizon and some others (no T-mobile, interestingly, even though during earlier efforts it was showing me that it was trying to connect to T-mobile).
Select Project F
Then in the APN section, change to custom, and put in APN h2g2
It should then work


Thank you! I will check it out for our application.

This seems to be a solid solution/approach.

1 Like

I’m trying to make this work with a data-only Project Fi SIM outside of the US. The big reason for using Project Fi for me is the international aspect of it. It’s interesting that in the US you were able to see a “Project F” network when scanning for networks and restricting, but this has not been the case for me in France or Spain. I really would like to make this work… any ideas? The carriers I see are:
voda ES 3G
Orange 3G
Movistar 3G
Shine 3G

I’ve tried selecting a few of these and using h2g2 as the APN as mentioned before, but I haven’t had any success. The connection status just says “Obtaining IP address” forever. If I just use Auto for the carrier, network, 3g/LTE settings, it seems to cycle through networks (the antenna status shows 5 bars, then after a while goes to none, then 4 or 5 bars again…). What is “Free” btw? Also, under carrier, it is always reported as T-Mobile, if that matters. and “Auto (AT&T / T-Mobile)” under Network. For Region, it is always “United States of America”

I’ve been unable to get it to work working outside of the US too. Works fine on my iPhone and shows Project Fi as the carrier. When I put the sim in the br2 and use the google apn g2h2 tthere is no Project Fi in network selection. In the British Virgin Island I choose the carrier Flow and it did connect but no data flow. Anyone have better luck?


The correct APN for Project Fi should be h2g2. Do you enable roaming for BR2 cellular WAN when you do the test ? If roaming enabled and you still failed to get the cellular WAN connected, please open a support ticket for us to further check on the it.

1 Like

Hi, I used the correct h2g2 APN, it was a typo in my response. I’ll be back in the BVI next week and try again with the latest firmware updates and I’ll open a support ticket if it doesn’t work. Do you know how to determine which carrier google partners with in various countries? Pretty sure it’s Flow in the BVI but not sure.




Has anyone been able to figure out how to make Google Fi sim work on the BR1?

Yes it works, we have about 20 our there, one in the Philippians.
Set the apn to h2g2
If shipping out of country I recommend putting the sim card it in a US device first when possible and make sure it activates for data.
Make sure you pick the correct peplink device we used a BR1 MINI APAC unit for the phillippians.
Make sure that you check the ability for data roaming.
It will automatically pick the partner cellular network it has a roaming agreement on.

1 Like

What is the BR 1 Mini APAC?

Is there another option? Thx

I believe ‘Free’ is one of the major cell carriers in France, maybe in Spain as well.

Did you ever get it all working as hoped?

I just also tried to get Google Fi working on the BR1 while in Spain with no success. It shows all the available networks but when connecting to one (one that Fi has roaming with) it gets stuck at “obtaining DHCP address” (I’ve entered the correct APN setting). When moving the SIM to a tablet it works correctly with same APN setting and using same network (in this case Vodafone ES).

So it feels like this is an issue with the BR1 specifically.

Hoping someone has a workaround I haven’t tried.

Actually, my mistake. I didn’t see the roaming box until now. Got it connected and working after clicking that as well and applying.


I am currently in Grenada and cannot get Digicel to come up in a manual search. I’ve been successful in all the other islands except here. Strangely enough, my iPhone automatically switched to Digicel when aid arrived! Auto or manual and data roaming selected on the BR1 mini doesn’t work. Any ideas?

What BR1 mini do you use?

Maybe Digicel uses a frequency not supported by your BR1 mini but well by your iphone.


Also make sure you have roaming enabled in the peplink.

1 Like

Yes. Roaming is enabled and has worked all over the Caribbean except Grenada.
My model is Max BR1 LTE US T

Thanks for any info!