Pepvpn rdp computer name


#1

I would like to rdp to a remote PC behind a PepVPN by computer name rather than IP address, since some of them use DHCP.

How do I set up the local/remote vpns so that the computer names are resolved at the remote site’s DNS server? Right now, if I try to ping a remote computer name, it is not found; but it is ping-able by IP address.


#2

Hi,

I assume you used Balance router as DHCP server at HQ and remote site.

  1. Enable Wins server on HQ’s Balance router (Network > LAN > DHCP Server Settings > WINS Servers > Check “Assign WINS server” > Select “Built-in”).

  2. Enable Wins server on remote’s Balance router (Network > LAN > DHCP Server Settings > WINS Servers > Check “Assign WINS server” > Select “External” > enter HQ’ Balance router LAN IP).

Hope this help.


#3

Thanks TK. I think I’ve set this according your instructions, but I could not ping from the HQ side by computer name. Then I realized that DHCP on the remote side was not working, since one of the PCs could not get an address.

The remote side:


and the HQ side (local):



#4

Hi,

Do you mean PC A (at HQ) can’t ping hostname of PC B (at HQ)? If both PB are under same network (same broadcast domain), then is nothing to do with Wins.

Your settings are correct. Please ensure remote side PC can grab IP from Balance router. You may need to check the network connectivity there.


#5

I think I’m very confused.

I am at 192.168.10.0/24 trying to ping hosts on 192.168.1.0/24. The 192.168.1.0 LAN is an Active Directory domain. The one where I’m at, 192.168.10.0, is just a peer LAN.

While logged onto 192.168.10.12, I can ping any host on 192.168.10.0 either by IP or hostname. From this same host, I can ping any PC at 192.168.1.0 by IP, but not by hostname.


#6

Hi,

Understood. Are you using latest firmware version for both Balance routers? If not please upgrade both units to latest firmware version.


#7

I believe so. They both are running 6.2.2 build 2037.


#8

Hi,

I tested it is working. Please ensure both PCs are pointing to WINS server 192.168.10.1 (check using ipconfig/all if you are using Windows PC) and reboot both PCs and test again.

If steps above doesn’t help, please open ticket for us to take closer look.