Peplink POC connectivity issue

Hello. I am new implementing Peplink equipment and we have received a request from a client to present a small Proof of Concept.

For this POC we have decided to use 2 Peplink devices (Balance 20 and UBR LTE), due to the lack of WAN links to perform the POC, we have connected the devices as follows


Then we have created from InControl2 a SpeedFusion tunnel between Balance 20 and UBR LTE, as shown in the following screenshot


Apparently the tunnel is created correctly but when we go to the connectivity details of each equipment, the establishment of the tunnel is not completed because it does not advance from the ¨Starting¨ state


Both PCs have Internet access. Pinging from PC-A to PC-B works fine, but then pinging the other way (PC-B to PC-A) does not return connectivity.

Please, I would appreciate any suggestions that could clarify why the tunnel establishment is not completed and why the connectivity from PC-B to PC-A is not achieved.

Thank you very much in advance.

Can you give more detail on what concept you are trying to prove? And also - why a balance 20 and an UBR LTE instead of a balance 30-LTE? That is a low cost dual WAN with LTE unit. They work very well.

With the gear you do have in place I would create the speedfusion vpn manually, not via in control. It may not understand the fact that one is behind the other…likely trying to connect from WAN of UBR to WAN of B20

@jmpfas is exactly right that IC2 is attempting to create connections between the two routers using the WAN IP addresses, so they aren’t able to find each other. It might help to know what the end goal is so we can understand the reason for wanting to put a second router behind the first and connect over speedfusion. With the routers being physically connected we wouldn’t expect to see a SpeedFusion tunnel between them, particularly WAN to LAN.

The reason PC-B can’t reach PC-A is likely because the default gateway on PC-B (assumed Balance 20 LAN IP) isn’t aware of the network.
You’d need a static router set up in the Balance 20 to send any traffic with a destination to the UBR at

1 Like

The main idea is to show the client how to form the SpeedFusion tunnel and that the networks at both ends of the tunnel can be easily reached.

These equipment (B20 and UBR) are used because they already had them from previous projects and the purchase of new equipment for this POC was not planned.

I’ve been reading about how to form the SpeedFusion tunnel I must have at least one public IP address, something I don’t have directly on the Balance 20.

I have already deleted the tunnel profile created from InControl and I have created a new tunnel manually from the Web Admin. It still remains in the ¨Starting¨ state.

They tell me that I can try as a solution the connection from a WAN port of Balance 20 to the WAN port of the UBR, the problem is that I already have the 2 WAN ports available in Balance 20 occupied, I would need a license key to activate the third.

Any other suggestions?

If you have a USB-Ethernet dongle lying around, shove that into the Balance 20 and you can use that, note you need to click the blue question mark on the USB settings and switch it from expecting USB cell modem to USB ethernet but then you can configure it just like the other two Ethernet WANs.

Thanks for the tip. I will try the USB-Ethernet dongle, I had read that this function was not supported by the Balance 20 before, but it seems it has already been enabled.

In this case, what would be the IP address of my Remote Equipment (B20) when configuring the tunnel from the UBR LTE?

You have two big /24 subnets on the WANs of the Balance 20. Plug the UBR WAN into a spare LAN port of one of the ISP routers and let it have one of the spare IPs from those ranges.

Or just put some SIMS in the UBR…

I have already managed to set the SpeedFusion tunnel but Hot Failover is not working.

In Balance 20 I kept the two links from the ISP. I connected the WAN port of the UBR directly to one of the modems, I also activated Wi-Fi as WAN (both in priority 1) and inserted an ATT SIM card (priority 2). When I disconnect the cable from the WAN port on the UBER, as a test, it takes more than 1 minute to switch to Wi-Fi WAN connection, but if I disable Wi-Fi WAN never failover to SIM connection.

In the other sense, if I disconnect one of the ISP links from Balance 20, it will not failover to the other ISP link either. In fact, it does not allow me to set priority 1 for both links in Balance 20.

Any suggestion?