Peplink Max Mini BR1 problems

I am having lots of issues with the Peplink Max BR1 - and wondering if there are some ideas on how to fix these. I would rather fix it then return the unit.

So - here is the situation- I have a Verizon SIM, and a static IP from verizon.

Here is what happens - either it sits there and alternates between “connecting” and “obtaining IP” over and over but never connects.

The other state is - it says “SIM PIN required or Incorrect”

I found out that I probably have to put mw01.vzwstatic in the APN - but now I get the SIM PIN thing on two different devices

I spent over two hours messing with this yesterday and I need to get a solution. We put the same sim into a cradlepoint and it just connects with no issues at all, also a d-link no issues.

Also is there any support number for this product or help getting it setup?

Thank you!!
ps I think we are on firmware 8.0


Would you please upgrade the device using the latest firmware and verify again ? You can download the latest firmware using the following URL :

If the issue still persisted using the latest firmware, you can open a support ticket to allow support team to check on the issue :

1 Like

which firmware would I need for the Peplink MAX-BR1-MINI-LTE-US-T-M BR1

I don’t see it specifically listed - or how do I identify which hardware I have specifically?

Hi @batcavenet,

For MAX series devices latest firmware version is 8.1.0. You can check your device hardware version in the status tab under device section.

1 Like

do you know in general if we have a static IP with verizon and a good sim- should we have to enter a pin or APN anywhere or should it just work?

FWIW: We have deployed Verizon SIM cards with static IP addresses across devices (HD2s, BR1s) for a number of years. In the early days we had to enter the APN for the static IP, but that seems no longer necessary. I have not encountered a request for a PIN. (The SIM cards were all delivered from Verizon without a PIN set, and we never set the PINs ourselves).

Good luck,


1 Like

It turned out the SIM had a pin associated- we had to put in

mw01.vzwstatic for the APN and the pin number from the account.

Then it started working - not right away but it did.


I had another one just start from working to “connecting” and nothing would fix it. I tried the APN, the pin code - mw01.vzwstatic and upgrading firmware and everything else. It did not connect. I ended up replacing it for another unit- but this is the 2nd one so far that has done this. Any ideas? do these not handle static IPs very well with verizon- or any idea what could be causing this?

FWIW: We have a number of Verizon static IP lines, two of them in BR1 Mini LTEAs, and they have worked flawlessly.