Peplink MAX Adapter 5G device

Problem reported in starting a Peplink MAX Adapter 5G device in Chile (Latam).
Visible connectivity is not achieved (it does not appear connected to the 5g network). Not so, with the other networks (3G, LTE) which work without problems.
Browsing speed is tested in different LTE networks which, although it showed good results, it was not possible to appreciate any available or attainable network of the 5G type. We tried 2 SIM providers, with the same result. Tests are carried out in different areas of 5G coverage indicated, all of these without success when searching for a 5G network.
At first it was thought that real coverage is not the same as the one indicated by the provider, but in 1 case navigation results were obtained above 200 Mbps. For this reason, it would be appreciated to confirm:

  1. Whether or not the device should be connected to a 5g network (via Peplink connection manager)?
  2. What is the 5G network connection test method that you recommend us to use?
  3. How can we force the connection to 5G, using the 5G adapter connection manager?