Peplink loses internet connection intermittently wireless and wired lose connectivity

Newly installed Peplink Surf SOHO loses internet connectivity intermittently it appears to be the Peplink as I have had internet signal checked a few time from provider prior to the installation of the SOHO there was no problem with connectivity dropping. Both wired and wireless disconnect and in a few minutes they come back.

Hi, were you able to find the cause of your connectivity drops? I’ve been observing the same symptoms the last few weeks.

In case it matters, the router’s Health Check Setting is set to DNS Lookup and I use and

Firmware 8.2.0

As a first step, let’s find out what role the health check feature is playing in this. What happens if you turn this feature off? This feature is really important in a multi-WAN environment; much less so when there is a single WAN.

Then, I’d suggest using ping with two different owners – e.g., and

Any change?

Thanks, Rick, for your suggestion. I’ve disabled the Health Check Setting; I will report results in a few days.

Within a couple hours after disabling Health Check Setting, the router experienced another outage. As usual, it resolved the problem in 3 to 4 minutes without my intervention.

I’ve now set it to ping the two suggested addresses.

do the logs say anything?

I’m looking at the device event log and there’s nothing that looks suspicious around the time of the dropout.

I had something similar happening, solved it by exporting my config, resetting my router to factory defaults, and then importing config back in.

Thanks, erutan, I’ll keep this in mind. I’m still monitoring things with the Health Check Setting as suggested by Rick. to ping two different hosts.

Had another disconnect. This time it recovered fairly quickly, maybe in 15 seconds or so, then dropped again after 10 seconds. Second recovery took a few minutes as usual.

are you using wifi wan or just lan?

@mystery, just WAN.

Yesterday I reset the router to factory default settings and imported my configuration. I still had 3 dropouts after that.

This morning I disabled Health Check and still experienced bad connectivity during the day.

Maybe the hardware itself is failing? Any negatives about reverting to 8.1.3, my previous FW version? Actually I updated to 8.2.0 on 02 April and that date seems to correspond with when I started having intermittent connectivity issues.

I’m debating doing the same thing - it’d be nice having the dynamic weighted bonding for speedfusion cellular connections from 8.20, but I’d prefer it to be stable.

I reverted to FW 8.1.3 but no joy. Drop outs are becoming more frequent, every 10 - 15 minutes.

I wonder if my unit has been damaged by heat? I’ve had a cable modem stacked on top of it for the last several months.

The attached log shows 2 used ports going down and then after they recover, the unit restarts.

One odd thing I did notice. Whenever I log in to the Dashboard page, there’s a message at the bottom about “Changes Applied” but no configuration was changed before the unit restarted.

Sorry to hear 8.13 made it worse. :frowning:

Mine is in a well ventilated relatively cool space, so with similar issues I doubt yours has heat damage.

I almost wonder if it has something to do with the modem? Reason for me asking this is because I experienced almost the exact same issues like others mid-late April. However, I will say that I was getting a “WAN failed DNS test” error in my logs; it’s unclear if others are getting this error. I searched for solutions here, and came across the same workaround for DNS health checks, but that alone never helped.

Seemingly I was able to solve my issues by ‘quick’ resetting the modem, then factory resetting my Soho and reverting back to 8.1.3 (8.2 is when I started having this issue), and finally, keeping health check enabled while using different public DNS servers as suggested. Kind of a scorched earth approach, so I don’t know which of the three actually fixed my connection issues. With that said, I’m approaching 2 weeks with no drops. I just wanted to share my experience.

Interesting and thanks for sharing - I’ve tried the first two, and the third didn’t help alembic at all, but perhaps doing all three in quick sequence is the trick. :confused:

Did you restore your config after doing the factory reset or rebuild everything by hand?

I’ve had a measure of success. My VPN provider’s WireGuard client triggers drops within 10 - 15 minutes on 8.1.3. It fairs better on 8.2.0, dropping 3 or 4 times a day only. So I switched to OpenVPN protocol and my router is stable again. I’m a bit surprised with this discovery. Can anyone shed light on how WireGuard could make the router unstable?

BTW I no longer stack the cable modem on top of the router. The router was slightly hot when I removed the modem; heat definitely does not help with electronics longevity.

My Duo will drop even with no VPN involved doing video calls on an iPad or laptop - I’ll sometimes run Cloudflare warp on my laptop or Apple’s private relay on my phone, aside from speedfusion I don’t run a VPN on the router itself.

Prior to this month I think we had one call drop on cellular - now it’s a good day when that doesn’t happen, at the worst the router will just not serve any data for long periods.