Peplink behind NAT


#1

Hi,

I’d like to configure a VPN IPsec as shown below.

One of my peplink is behind a box in router mode with NAT activated.

Below messages are displayed on both peplink:
“Malformed payload, please verify the Preshared Key or other settings.”
“No acceptable response, please verify the settings.”

When I switch my test box to “gateway” mode (no NAT) the VPN connection is established so the configuration (VPN/Firewall) seems to be OK and the issue seems to be caused by NAT

Informations:

  • NAT-T is enabled on both peplink
  • I’ve forwarded UDP 500 and 4500 from my box to the peplink (other ports to forward or IP protocols to forward?)

Is there something else to do?

Thanks.


#2

I have solved my issue by defining Local ID and Remote ID.