Peplink Balance310 - Corrupt SD

Hi All,

I have a Balance 310 and the SD Card inside the unit has died.
I have plenty of 4GB cards to replace it with, can i get the firmware to put on the drive to get it to boot?

currently it just flashes red status light upon boot.

We don’t do the hardware customization. Please submit ticket and request for RMA if this unit still under warranty.


1 Like

Yep, i did raise a ticket.
Is there no way to get an image of the SD Card?

Thanks for opening the ticket. Yes, RMA is the only way.

1 Like

I know this is 2y old but I’m having the same problems as you Matt - have you resolved this issue?

In case others have this problem. I have solved it by cloning the SD card to a new one. Read more here.

yes. it’s a common problem. got the same one on the same Balance 310 hw 3.
very sad about helpdesk feedback basically “yes it’s a hardware issue, so be it”.
instead should be proposing to sell an SD card replacement, with the firmware on it.

anyway, the problem could be solved if the router is booting yet - means the active boot partition is alive.
the rest could be restored (the content of non-boot partitions I mean, will be restored by the router itself).

myself recovered the content of the SDcard by using relatively old laptop with a very good MMC card reader (not the cheap USB bridged crap ones integrated in some new laptops but the real MMC).
managed to duplicate card using linux dd tool (no chances with windows as the card reading fails on physical level).

  1. boot live Ubuntu USB
  2. open gparted and fig-out what device is your source (/dev/mmcblk0 was in my case) and the destination (/dev/sdb or something else new SD card over USB was mounted, I used USB sdcard reader for the destination drive)
  3. run terminal
  4. run following command:
    dd if=/dev/mmcblk0 of=/dev/sdb bs=1M conv=sync,noerror
  5. from another terminal you may run “progress indicator”
    watch -n5 ‘sudo kill -USR1 $(pgrep ^dd)’
  6. wait for the the end of card content being copied
  7. comeback to the gparted with the destination SD card
    will find 2 primary encrypted partitions, then 1 extended (empty in my case)
  8. rebuild the content of the extended partition with the following logic partitions:
  9. 500M ext3, 2. 500M ext3, 3. 250M Swap, 4. leftover as another ext3
  10. the new SD card is ready for the router to boot-up (if you got lucky)

Do you have the image files you used to restore the peplink. I also had this issue now. Would you please help to share the image files you have ?

Hi i did this and managed to recover the SD card data and clone it, I’m going to save you all a whole lot of trouble, I tried 13 different “disc cloning utilities” none worked, they all insist on messing with the partitions and data in one way or another during the cloning process, clearly they do not understand what “sector by sector” means… use DISKGENIUS to copy it, is the only thing that will REALLY clone sector by sector without touching the data, even on damaged CF Cards, however upon boot I get this error on the WANs:

I’ve tried this with 2 different Peplinks 710 one HW1 and one HW2 same problem, they both show activation error, the second I place back the original SD card it works again, so somehow it knows I replaced the card, but the cloning process clearly worked since it does boot, I mean c’mon Peplink these are production operation critical units, we need to be able to repair this things immediately, I cant wait for RMAs or 30-60 days on a new unit order I need this thing fixed and back up and running NOW…

The activation nagwall is a kick in the… the data on the card is fine, it clearly is because it now boots (when before it did not) I can do firmware updates and reflashing of the SD but I cannot even connect it to the internet because Peplink “doesn’t want me” to replace the SD card

What’s the big deal with blocking it via activation? it CLEARLY can tell its running on Peplink hardware, the encrypted boot image is decrypted and running, so its not like its running on another hardware, why does it need activation? this thing should just work when having the SD replaced, its critical hardware that due to policies outside our own we cannot replace (the customer demands replacing the whole system if were replacing anything outside of the original specs, big oil loves doing this stuff for us IT guys and wrecking our lives), doing that its a nightmare in paperwork and near impossible to convince the customer to do it

Were Peplink certified engineers, been selling these things for more than a decade, please just let us activate them with our partner portal key, the only people you are hurting with this activation nagblock is your engineers and your resellers, customers do not see or will never see this message, and if the thing isn’t working they don’t care why, we promised high reliability and were clearly not delivering due to an inexplicable intentional block on software that isn’t even relevant anymore.

but enough ranting /rant off

If anyone knows how to bypass this … activation block id be extremely grateful

Right now I’m going to have to replace the burned out damaged SD card back even if it doesn’t always boot, just so I can get the thing to boot and the customer back up and running. load the config and just hope it runs for a while longer, not an ideal situation.

But with the SD Switches 3x more expensive than the competition, then the outsourced AX fiasco and finally this were reaching the end of the rope here, throw us a lifeline peplink… please…

Sorry for the rant, it took me 3 days to recover the data from the CF card with the customer breathing down my neck asking when will the service be restored only to find out that after all that work it did not work due to an artificial lock… its just frustrating

So in the end the solution was to plug one of the spare WANs of the secondary Peplink into one of the lan ports of the broken 710, if it ever resets and looses the config i can turn on the wan on the Peplink that does work and reflash the config, which will work until it looses, power, absurd and in no way an acceptable solution for operations critical equipment but hey we tried doing it the right way… i hope there’s a way to bypass the activation so we can fix this properly

Did you create a ticket for this, and it was denied?
I had the same activation issue on a HW4 Balance 380 where the CPU was fried. Given the CPU was soldered directly onto the MB, I found it easier to replace the entire MB with a similar type and got it booting only to find the same issue with the activation like you did.
Frustrating indeed.

Did you try dd like @ole2 did in step #6 Peplink Balance310 - Corrupt SD - #6 by K0gen

I haven’t tried, but I feel like some data didn’t get copied.