Peplink Balance with modem in bridge mode

Hi all, my modem connects to a router and gives it an external IP address, I assume that means it runs in bridge mode. My DSL modem has a router built in and connected to WAN 1 and working fine, so I tried connecting the cable modem to the WAN 2 port on the Peplink balance 20 and it gets the IP address and then immediately disconnects. It does this over and over and never stays connected. If I connect the modem to a separate router first, then connect the router to the Peplink, it works fine. Is there something in the Peplink that I can change to make it work directly with the modem?

Hi Andy - Welcome to the forum.


What cable modem? Which ISP?

There have been some weird issues with WAN ports and ISP modems lately. What model Balance do you have and are you running firmware 8.1.1?

Hi Martin, Its through Cox Cable and it’s a Motorola MB7420. I upgraded to 8.1.1 and I watched it a little more when I tried to connect it again this morning and the modem appears to reboot when it does the disconnect thing. All the lights go out for a second and then come back on. Sometimes it happens a few seconds after it gets the IP address and one time it lasted about 20 seconds before it rebooted. One thing to note is this modem is about 3 years old

I bought another surfboard modem with a router built in to replace this although I wouldn’t mind getting the Motorola working with it.