Peplink Balance One not able to handle 4 WAN connections for more than a day


I bought the LAN → WAN unlock for my Peplink Balance One. They are external devices that are sending the WAN traffic to the Balance One.

One of the WANs refuses to stay connected for more than a day or so. The Balance One reports it failed the WAN test (tried both ping and DNS). The actual Netgear Nighthawk MR5200 shows a solid connection with full bars. Manually clicking disconnect and reconnect in the Balance One interface does not restore connectivity. Neither does rebooting the MR5200.

The only thing I’ve found to work to restore that connection is to reboot the Balance One. Which is less than ideal. Looking in the Event Log, I am not seeing anything to indicate what might be going on.

Is there someplace else I can look? The trouble only started once I added the additional WAN4. Previously, this device was used in another WAN slot and functioned correctly with a different SIM card. The SIM card was previously in a Balance LTE and worked fine for years.

Try a different wan slot etc to do basic process of elimination. Do the nighthawk have a tether/pass through mode or whatever they call it (check the manual for it). A solid connection with full bars does not necessarily mean data is flowing and bandwidth is available.

If you disable health check does the connection work? What ip are you using for health check? When it’s not working, what do you see when you connect to nighthawk directly?

Disabled the health check and the connection did not work. I was not easily able to test directly connecting to the Nighthawk at the time.

It is odd that rebooting the Balance One (not the Nighthawk) is what fixes it.

Who is the carrier. It could be many different things… heck for 6+ months AT&T was having connectivity issues with their data plans and many routers/hotspots… out of curiosity, if you establish a speedfusion tunnel and turn off health check, does the tunnel stay connected?