PepLink Balance One: Full-Cone NAT-PMP?


#1

I’m running apple Messages.app in 10.10.3 behind a Peplink Balance One firmware 6.1.2. Under Inbound Access/Port Forwarding I have a few ports forwarded, but I also have UPnP and NAT-PMP both Enabled.

When I run the Connection Doctor test in Messages.app (Video menu, Connection Doctor, Choose Show:Network Status), it shows me that I have “Router Type: Port Restricted” A friend who is not behind a Peplink router tests it and it shows him “Router Type: Full Cone”

My questions are:

  • Are there any known issues with PepLink’s handing of NAT-PMP that could cause this?
  • Are there any known issues with Apple’s implementation that could cause this?
  • Any other ideas? (For example, perhaps my Port Forwarding settings are accidentally blocking a critical port?)

#2

By default, Peplink NAT behavior is “Port restricted”. But it will not affect Messages.app connection on MAC, if you enabled NAT-PMP. Also, we have not reported any issue about this.

Full Cone can be done by configure One-to-One NAT via NAT mappings, which maps the public IP to internal IP of your computer. It would be normally used if you have a server on LAN side, and we would not recommend to use it for computers/workstations. As all TCP/UDP ports will also be forwarded to your computer, and your computer will be likely putting on public Internet side.