Peplink Balance 50 slow internet problem


#1

I’ve recently set up a client with a Peplink Balance 50 that is connected to 4 internet connections - the first two are 175 Mbps fiber and the second two are 80 Mbps cable (I told him that this was overkill, it will likely be scaled back soon). The problem is that we’re getting very low throughput to the internet. There are about 65 clients in a residential setting where their individual connections are limited by layer 2 switching. However, people are having trouble getting even an 8 Mbps connection to the internet, which should be a piece of cake given the available bandwidth. I’ve gone through the forum and the internet, searched for answers and played with settings and I can’t figure out what’s going on here. This is my first time working with a Peplink product, but I do have a background in small business networking … does anyone have any ideas for me to try?

Thanks,

Brian


#2

Hi Brian- The Balance 50 has a rated throughput of 100Mbps and your total capacity well exceeds 500Mbps. i would definitely recommend the Balance 580 in your application.


#3

Hello Brian,

Please take a look at the model comparison chart, specifically the “Router Throughput” for each model.
I’m not too sure if you are referring to the download speed when you say 175Mbps and 80Mbps. However, please be aware that “Router Throughput” in the chart includes both download and upload speeds. I hope this information helps to select the appropriate model as well.


#4

Tim … We’re having trouble getting more throughput than about 12 Mbps … I’m going to have a hard time convincing them to upgrade anything if I can’t even get 1/8 of the throughput that this box should be capable of. I had originally sourced the box based on a completely different idea of what was going to be in place for the internet connection … although this project has come with a lot of surprises. Do you have any idea why this box is underperforming? Any settings that I could check? If I can cap this out near 100 Mbps then I can make the case for the upgrade at that time. If I can’t get it there, then it’s going to be a hard sell.


Attached image is current throughput graph … currently a few hundred (300-400 ish) outbound sessions across all clients, protocols and WAN connections.


#5

Brian- for troubleshooting purposes I recommend to disconnect the LAN segment and just use your PC to test each of the WAN’s through the Peplink. The default MTU size is 1440 so you could try bumping that up.

If needed, you can open a support ticket for further investigation:
http://cs.peplink.com/contact/support/


#6

The site where this is located is actually almost an hour and a half away from my office, and I don’t currently have access to it other than through PPTP VPN because they’re a little ticked off right now. So I can’t physically manipulate the network, only muck with settings remotely. I’m just trying to work my way back into their good books, which is proving to be difficult because I can’t come up with a good reason why this is happening …


#7

Hello,

If you could create a support ticket and provide remote assistance access we can certainly take a closer look.

To enable RA:


#8

Support ticket is 746015.

RA is turned on.


#9

I’m having the same problem with my Balance 50. I can’t break 10mbit when I have 6mbit DSL line 1, 6mbit DSL 2, 50mbit cable modem. there is a definite bug in the Peplink routers. Even if the device had only 50mbit of a limit on throughput I should be doing far better. This is just silly. I plug directly into the modems and get full speed. I also made a post here https://forum.peplink.com/threads/2012-Resolved-Slow-Internet-Speeds-when-connected-to-Peplink-Balance-210 where someone fixed it by setting the port to 100mbit instead of auto. Didn’t fix it for me. I can’t be the only person having this problem. Well obviously I’m not since bnetworked posted. Did you fix his problem?


#10

They were unable to resolve my issue, but that’s because we eventually diagnosed the problem as relating to the throughput capability of the ISP’s equipment and we rectified it by replacing the ISP supplied gear with higher quality equipment. This diagnosis was attained after consulting with Peplink, but was not a result of anything that they did because it was not their equipment at fault and further troubleshooting was required to dig deeper into the issue on our end.


#11

@bNetworked,

Thank you for sharing the results and glad things are at the expected speeds!

@Aaron Holio,

I would ensure that all connections set the MTU size to auto, as well as ensuring you are on current firmware:
http://www.peplink.com/support/downloads/balance-firmware-and-user-manual-6-2/

Also, ensure that you have a weighted balance rule setup at the top with all connections at 10 when testing to ensure that the speedtest is utilizing all WANs in the test.

If you are still having issues, please create a support ticket and we will help diagnose the root issue. (Balance 50 is rated for 100Mb of bi-directional throughput).
http://cs.peplink.com/contact/support/


#12

I have similar problem but it’s way worse. WAN connection to Peplink Balance 20 comes from CISCO box by ISP. Connection speed between me and ISP is 400Mbps. CISCO box has 1Gb ports. Peplink has one LAN client - ASUS RT-N66U that also has 1Gb ports and it serves home network. For failover connection I use 3G dongle and it is in stand-by mode so it’s used only when CISCO is down or performs bad.

Now the problem with Peplink is - I get very low bandwidth measures:

  1. Downstream - max. 30 Mbps (ISP has 300 Mbps)
  2. Upstream - max. 40 Mbps (ISP has 40 Mbps)

Some years ago I saw way better metrics by this device - maximum download speed I got was ~100 Mbps. I’m using latest firmware.

Is there anything I can do get download speed up again?


#13

Hi,

Balance 20’s WAN port supports 100Mbps. So this is the maximum throughput on this port. Please fix 100Mbps Full Duplex on Balance 20’s WAN and Cisco’s port then test again.

If you need Gigibit WAN port. Please consider Balance One and above. Please find here for more details.


#14

Dear All

we have peplink balance 20 in office and we have 100 MBPS line but we are getting only 5 MBPS internet please help me in this issue


#15

I HAVE FEW DOUBTS CAN ANYONE CLEAR IT PLEASE
which of the following max supports cellular wan through passtrhough mode?
max-on-the-go
max BR1
max BR2 ip55
max HD2
max HD4


#16

The MAX BR1/BR2 support IP passthrough mode.


#17

@santhosh, you should check the duplex settings for the WAN connection and set it to 100Mbps Full Duplex and MTU to auto.

If you are still experiencing issues you can open a support ticket for further checking:
https://contact.peplink.com/secure/create-support-ticket.html


#18

Thank you Tim.s

internet speed increased now my internet download speed 10 MBPS and internet upload speed 20 MBPS but we have 100 MBPS line


#19

@santhosh, have you tried testing it by connecting PC directly to the ISP modem and bypass the Peplink?


#20

I got speed issues solved and it turned out that network cable was the slow part. I took new one and now I see that speed is actually increased over firmware versions. I was able to get 170 Mbps as download throughput instead of 130 Mbps that was the record with older firmware. These numbers are from speetest.net and from router dashboard (they usually match pretty well).

Also I got Huawei E3372 mobile dongle work with Balance 20 although it’s not mentioned under my mobile support package. I got 5 Mbps download speed instead of 21 Mbps but this is something I will focus later. Anyway good to see that there’s at least one router manufacturer that supports mobile dongles available where I live :slight_smile: