Peplink Balance 30 w/ Embedded LTE fails Smartcheck

I took the SIM card out of the Hotspot Modem (AT&T) that was working just fine. I put it in the Peplink Balance 30 w/ Embedded LTE and it seems to connect fine, gets an IP address etc, but it fails SmartCheck. When I put it on DNS for health check, it passes but there is no internet connectivity. I’ve tried setting it specifically to AT&T in the settings, but still no joy. Any ideas? this is NOT a SIM card from a phone or a tablet, its from a fixed hotspot device. Any help would be MUCH appreciated. I upgraded from an old Balance 30 to this with the built in LTE to get rid of the hotspot and have some of the new features.

Sadly, I can find no answers to this issue and will be returning the item.

Hi. This is not expected behavior and is inconsistent with our experience. Questions:

  1. What happens when you set DNS health checks to and
  2. What happens when you disable health checks?
  3. Have you set the APN as required by the carrier?
  4. Have you tried to set the APN to “Auto?”
  5. Is the ethernet WAN OK?

In general, issues like you describe are commonly a result either of the device not being supported by the carrier or an “APN issue” – with the latter being more likely.