Peplink Balance 30 - Mobile Internet


#1

I have had limited success tethering my Samsung Galaxy S3 to my Peplink Balance 30 through the USB port. It has worked in the past, and when my phone is connected it always charges, but right now I experience these two things most often:

  1. The “USB ththering” option thinks that “No USB device is connected”
  2. When it does allow me to tether, it does not seem to properly share the 4G connection (i.e. I can not load a web page).

I know this has worked in the past. I’m just wondering if anyone has gotten this combination to work with a higher degree of success than I have. It would be really nice to have this as a backup Internet option when my main provider’s service is down.

Best,
Shannon


#2

Hi Shannon-

As long as you are subscribed to a tethering plan with the carrier it should work just fine. Can you confirm you can tether via USB to your PC directly?


#3

Yes, tethering works fine on my PC. I just get the behavior discussed above when connecting to the Peplink Balance.


#4

I have an S4 that I experience the same thing with. It will tether with the Balance or Max On The Go, show connected, and even get the proper IP address that it shows when tethered to a PC but I can’t pass any data over the connection. Would be nice to throw my LTE in as a backup without needing a separate data plan.