Peplink 380 5.3.9 - IP in IP (protocol 4) not working ingress


#1

Hi I’m using Peplink 380 and recently upgraded to 5.3.9 as I was interested in the new IPSec site to site feature. After trying it out a bit I decided perhaps it wasn’t mature enough to use yet. I couldn’t find any debugging capabilities so I decided I didn’t want to use it.

I was doing IP in IP tunneling (protocol 4) on 5.3.6 before I upgraded and now that I’ve upgraded to 5.3.9 the tunnel won’t work any longer. I downgraded back to 5.3.6 and it won’t work there anymore either so I upgraded back to 5.3.9.

What I’m trying to do is setup an IP in IP tunnel going through Peplink. This worked for me previously on 5.3.6 but now that I’ve upgraded to 5.3.9 I can’t seem to make it work. I tried downgrading to 5.3.6 and it won’t work anymore there either.

I’ve confirmed with tshark that I’m seeing the appropriate protocol 4 traffic going out of the Peplink to the remote device. The remote device then replies and it doesn’t make it through the Peplink back to the internal device.

I did go into network->Inbound access/services-> and created a rule that would match on protocol 4 and map that service in from the appropriate wan interface to the internal server.

Any ideas?


#2

I thought I’d put an update on here. I added yet another tunnel GRE (protocol 47) and it appears to be mapped ingress.

Though when I go to status->active connections the webui states that its protocol is GRE with the correct src/dst and a service of PPTP. Since its a GRE tunnel it shouldn’t be calling it PPTP service as its not PPTP.


#3

Hello,

Please open up a support ticket with us for this issue. We would request that you submit a diagnostic report from your 380 so we may view your configuration. Instructions for obtaining the report are in the following link:

Best regards,

Ron

The Peplink Team