Peplink 310 time set issue (+ possibly related ping tool issue)


#1

Hello, I represent a small company that has had a Peplink 310 installed at our office for the past 1.5 yrs or so. Unfortunately, it’s the 310 model without the gigabit lan ports but that’s another issue.We’re running v5.2.2 of the firmware. For a while now, I’ve been unable to get this unit to correctly keep time. Despite pointing to the pool.ntp.org server(s) for ntp service, the unit(after a restart and being at lease close to correct time) seems to start losing minutes within a few hours and by the time a week goes by, will be off at least a couple of hours. Viewing the logs, one can clearly see this entry upon restart of the unit: “System: Time Synchronization Fail” Yet I will point out that the box does reset the time correctly(again close enough if not precise with other machines using ntp and pool.ntp.org). I’ve correctly selected our timezone and that’s about all you can do, right? In an attempt to debug this situation, I have tried the Ping tool on the unit and intriguingly got a Result of: “Selected interface is disconnected or not available”. Hmm, tried both WAN ports and multiple destinations for the ping(pool.ntp.org, google.com, etc…). Same error. Yet I can assure you that WAN connectivity works fine.---------------------------------------Huh! It finally dawned on me to try the Ping tool with an ip address rather than the domain name and sure enough, it worked! And so did ntp, after I found a pingable address from the pool.ntp.org pool. So my question has become, why is this happening? No, I do not run/enable a DNS server on the 310 but the WANs do have DNS server info assigned to them. WAN 1 with fixed DNS server addresses while WAN 2 is configured to use DHCP. But the unit is clearly having a DNS resolution problem. Why? Sincerely appreciate any insights into this misconfig/bug/??? Thanks.