Peplink 20 incorrectly reporting WAN link failure, still routes outbound traffic


#1

Hi, I have a Peplink 20 installed in a small office, so far it’s been quite reliable. Either late yesterday or early this morning (our monitoring system switches off for a network maintenance window through the late night/early morning hours to reduce false alarms) from outside we noticed the device was no longer forwarding requests to NAT’d internal devices (nor was the router administrative interface accessible remotely). It was responding to ping requests on the WAN interface.

Onsite this morning requests originating internally were going through fine, and once a session was established by an internal device two way traffic worked fine.

In the administrative interface (still only accessible on the LAN side) the WAN interface (they have a single Internet connection at this time) reported its status as ‘failing health check’ on the dashboard. It was set to periodically query the first two DNS servers. From the LAN side I ran a variety of queries off of those DNS servers (at our ISP) and they responded as expected. I reconfirmed that port forwarding wasn’t working from the WAN side.

I disabled the health check on that WAN interface, applied the changes, and confirmed the problem persisted. I re-enabled the heath check, disabled the interface and re-enabled it. After over a minute the dashboard still indicated the WAN interface was in the process of ‘connecting’. I disabled the health check on the WAN interface and applied and that WAN interface came right up. However the symptoms persisted.

I re-enabled the health check, which quickly failed, although the interface remained up and outbound traffic still worked. I confirmed throughout this that inbound port forwarding never came up.

I then rebooted the router through the administrative interface. When the router came back up, all symptoms disappeared.

Anyone else run into anything like this/rebooting their Peplink 20 to clear problems? I’m running 5.2.2, a quick look at the 5.3 documentation doesn’t seem to have a bugfix section, don’t know if this is a known problem.

Thanks,
Josh


#2

Haven’t come across anything similar and after a few read still couldn’t pin-point your experience to any single factor that we could think of.

We do have a number of stability enhancements since 5.2.2 that should be of help. Let’s upgrade to latest firmware 5.3.12 once we have a chance, shall we?