PepLink 20 / ATT UVerse


#1

Hey,
Just got my PepLink Balance 20, so far with just one WAN , my ATT UVerse/RG. The Uverse “Residential Gateway” device is an all-in-one beast with limited configuration (unless there’s a hidden operator menu).

My Original Config:

  • Wire RG configured to serve DHCP 192.168.2.0/24 and WiFi – 1 LAN output to -->
  • smart Switch GS108T at 192.168.2.10 – 8 ports filled with assorted devices

I thought I’d just insert the PepLink like so:

  1. 2Wire RG configured for WiFi – 1 LAN output to -->
  2. PepLink 20 Balance (WAN1 to ATT/RG), DHCP 192.168.2.0/24 … LAN-1 to -->
  3. smart Switch GS108T at 192.168.2.10 – 8 ports filled with assorted devices

I’m struggling to get the WAN configured correctly.

First problem is that I cant seem to turn off the DHCP server on the LAN side of the ATT/RG… which may be the root of my other problems

a) Can I have two DHCP servers on my 192.168.2.0/24 network – the ATT/RG and the PepLink? maybe each serving out a smaller section of the 192.168.2.0 ranges?

Second problem – I’m not sure how to configure the WAN1 on the PepLink

  • PPOE - I dont have any access to the PPOE auth info in the ATT UVerse RG device (as far as I know).
  • Static IP - on the WAN side, My ATT Uverse service is DHCP’ing to their servers somewhere. This number doesnt change alot, but it does often enough…
  • DHCP - If I select this one, the PepLink WAN gets assigned a DHCP from the RG’s DHCP pool (192.168.2.100), which I dont think is the idea here. I think I’m supposed to “passthru” the ATT/RG and put the same DHCP/gateway/DNS info here that’s showing in my ATT/RG WAN status… which changes occasionally…

I tried to set peplink WAN-1 to a static IP on the ATT/RG’s IP list (192.168.2.1) and turned off DHCP on the peplink, but that wasnt really happy, I think the PepLink really wants to be in charge of the DHCP or have someone downstream of the PepLink doing the DHCP…

I even stripped out the switch from the config and just hung my macbook from the PepLink 20 LAN-1 Port, but was still missing something.

Am I fubar’d because I can’t turn off the LAN-side DHCP upstream from the PepLink WAN-1?

-Mark


#2

Some further browsing led me to:

From those two posts, it sounds like I need to

  • set my ATT/RG into Bridged mode

and/or move some subnets around to something like

  • ATT/RG - LAN:192.168.1.0/24
  • PepLink - LAN:192.168.2.0/24

Do I need to do both?

-Mark


#3

Hi Mark-

The recommended configuration is to put the ATT/RG in to bridge mode and let the Peplink WAN do the PPPOE. This way the Peplink WAN will receive an IP address directly from ATT. You will need their help to accomplish this unless you have access to these settings in the RG and you will also need to know your PPPOE credentials.

If they will not do this then you are forced to go with option 2, which is having a different subnet on the Peplink as you mentioned above. This creates a double NAT environment and is a pain to set up port forwarding, etc.


#4

just an update. ATT UVerse refuses to put their RG in bridged mode.

Other people have have developed elaborate workarounds http://www.ka9q.net/Uverse/static-ip.html ] but yikes. It’s easier for me to shop for a different carrier.


#5

Thanks for the update Mark. If I was a power user and had options for providers I would avoid the UVerse service, their policies just don’t make sense to me…