Parts of extended network not being assigned IP addresses by the Balance One master?


#1

Well, the title is what I think is happening.

This might be a little lengthy but in an attempt at full disclosure here goes…

I have a Balance one with Dual ISPs. I then extended the network with an Asus 1200G (in my home office which is hard wired back to the lounge where the Balance One is located) by creating a LAN-LAN network via the usual method i.e. increasing the secondary router’s IP (to 192.168.1.3) and disabling DHCP etc. All worked fine.

Some months later of everything working great I then decided that a further extension in the bedroom (also, but separately, hard wired back to the Balance One in the lounge) was required as I needed more wired ports to connect multiple streaming devices and a better WIFI signal. I bought another Asus 1200G and set it up with an IP of 192.168.1.7. Then the problems started!!

I did exactly the same as I did for the office but it did not work - the router (whilst emitting the new WIFI) could not connect to anything. For example, my phone would pick up the SSID of the new network but would not connect with the message ‘cannot get IP address’ or similar. My Amazon Fire TV box would not recognise that it was connected via a wired connection and the router itself showed no connection to the internet.

I then took that same router (without altering any settings) and swapped it with the one in the office. Hey presto, it worked first time! Meanwhile the router from the office that had been working perfectly from initialisation was connected in the bedroom and also would not work.

Further, I took both routers and connected them to a LAN port of the ‘Master’ router (i.e. the Balance One) in the lounge and both worked immediately. Phones connecting via WIFI and devices connecting via wire.

So, it’s pretty clear right? Both routers work as expected in the office and the lounge so…The cabling from the lounge’s Balance One to the office is good but the cabling from the lounge to the bedroom is not?

And that is why I am writing this - I am utterly confused…

I have an Amazon Fire TV box in the bedroom and if I connect it via the wired connection it works perfectly - streaming anything I ask of it (using the same cables I add). That is to the same socket in the wall that I connected the Asus router to that fails to recognise any internet.

So how is it possible that my router (with the correct settings that will work from my office or plugged via LAN into the Balance One) can’t seem to get an IP off the master router (Balance One) but the Fire TV connects/streams happily with the same wired connection? By the way, I ensured that the Fire TV was indeed connecting via the wired connection it claimed to be by changing the WIFI password and restarting it so it is definitely connecting via the same wired connection that nothing else can.

I am utterly confused! It seems impossible that the Fire TV will work but the router won’t as that indicates it can’t be the cabling. But if not the cabling then how can the slave routers work elsewhere but not in the bedroom? I desperately hope I am missing something obvious but after 4 days of head scratching I am at a loss as to where to go from here.

This is very possibly not a Balance One issue so forgive me for posting it here if that is the case but everything seems so illogical that I am wondering if there is some limitation with the B1 software that only permits one additional router and not two LAN/LANs.

If anyone can shed any light on this it would be hugely appreciated!


#2

You have taken good troubleshooting steps so far. There could be an auto-negotiation issue occurring only between the Asus 1200G and the Balance One. You may want to try locking down the Ethernet port speed/duplex settings on both devices next to see if that helps.


#3

Many thanks for your help and apologies for my slow reply but my time zone is GMT+7 so I’ve been awol for a while.

I attempted to do what you suggested and whilst I quickly found the setting on the B1 (I was going to try setting it to 100Mbps and full duplex - don’t know if that would have been correct). Unfortunately I can find no such setting on the Asus 1200G despite trawling through pretty much everything twice. So unless I’m missing it or it’s hidden then it appears not to exist on that router.

Meanwhile I tried something else, the result of which might shed some more light on things…

I have an old Mag250 streaming device so I connected that to the office LAN and it worked fine. Same when I connect it to a LAN port on the B1.

I then took the same device and took the LAN cable out of the Fire TV box in the bedroom and put it into the MAG250. It said ‘no internet’. So it is not just the Asus/Balance One that are not talking to each other. The Fire TV box connects fine to the LAN in the bedroom but neither the Asus router nor the MAG250 box will connect.

Given that all devices work on the Office LAN then one would be convinced that the problem lay with the cable from the lounge where the B1 is located to the bedroom were it not for the fact that the Fire TV box connects/streams without issues. This seems weird to me (although I am far from an expert) but is it at all possible that there could be a problem with the cable that is affecting everything except the Fire TV box i.e. it is ‘missing’ something that the Fire TV box simply doesn’t need/use? I know that sounds silly but when every device works fine everywhere except on the LAN in the bedroom then it sort of screams cable problem!


#4

Hi,

I would suggest to further test on the physical connection before you actually test on the network connection.

By the way, do you able to connect a PC using the LAN cable in bedroom ?

Thank you


#5

Thanks for your reply.

Unfortunately my laptop doesn’t have a LAN port so I can’t test that but as neither the router or the MAG box will connect then I imagine it would be the same with a PC.

I’m coming to the conclusion that despite the Fire TV box working perfectly the fact that everything works both in the lounge and the office means it really has to be something to do with the cabling. Why the Fire TV box works will forever remain a mystery. So I’m going to get an electrician friend to replace the LAN ports that connect the bedroom and the lounge. If that fails to resolve things I’m going to run a new cable from the lounge to the bedroom. I’ve been reluctant to do this so far as the cabling was installed through roof space/walls when the house was built 2 years ago and that no longer remains an option. To run a new cable will involve drilling through walls and having ugly cabling on display. :frowning:

If that also fails I give up!