Packet loss in SFP but no packet loss in single WANs

Hi, we have a Peplink Balance 310-5G and we have the problem that in our SFC Server we get packet loss even if we use 4 WANs and activate WAN smoothing. The server is hosted on VULTR.

Any idea what could cause this problem?

Thanks and cheers from Germany


is the 310 5G on the latest Firmware, if yes are you using Dynamic Weighted Bonding?
If you need help, feel free to contact me by telephone.

Best wishes from Munich

Hi again

after discussing some topics with Dennis Hofheinz on the tele (thanks for this) - I still have massive issues with our Balance 310 5G router and packet loss on the SFC side.

All single WANs are nearly perfect but on the SFC side I’m getting a constant packet loss amount of 10pkt/s. That is not acceptable and I have no idea what I could do to get rid of it.

I had this with SF on a VULTR machine. On AWS it was somewhat better. Today I bought a SFC packet and tried that because imho this should be the best option because it is hosted by Peplink. But even with SFC I don’t get any better connection - Packet loss constantly - even at a 4MBit video stream.

I even tried to switch from DP to TCP (Dennis suggested this) but that makes no difference at all. Still constant lost packets.

These are the settings:

Dynamic weighted Bonding
WAN Smoothing:
Overall Redundancy Level: Normal
Maximum Level on the Same Link: Normal

With these settings I get the result that is documented in the screenshot.

What I discovered:

If I switch off WAN Smoothing and activate FEC (high) instead, the packet loss vanishes. There seems to be an issue with the WAN Smoothing feature here.

Anyone with a solution to this?

Thanks and cheers

I wonder if its a bug in that it is showing discarded packets as packet loss.
Are you seeing performance issues due to the perceived packet loss?

Yes - I’ve a really bad experience now with our Peplink gear.

When I send a single RTMP stream to our streaming CDN it works. But as soon as I send a second stream to our CDN everything goes down the drain. Paket loss rises on the SFC side (not in the WANs) and I get lots of drops of the connection on the CDN side. There is enough of bandwith - If I test it in the Peplink 310 5G I have about 60-70MBit upload, but I can’t get two 4MBit streams through.


OK - now it’s getting really weird:

I setup a SF endpoint on AWS and monitored the remote WAN there. On the SF side there are no packet loss events detected. If I look at the local interface of my Peplink 310 5G there are lot of packets lost to SF.

first the screenshot of my Peplink device:

And here is the screenshot of the SF client on AWS at the same time:

I would really like to know what is going on here…