OpenVPN from my Desktop through a Peplink doesn't work

I have OpenVPN on my desktop which connects to a VPN server running on OVH which I use to send all traffic as we need Static IP authentication for an online ordering system we use. So I VPN in, my IP shows the IP of our VPS at OVH and that’s what authenticates.

When we switched to the Peplink Balance the VPN would connect, but no network resources or web sites would work or load. So I thought it was because I was connected to Google Wifi which was then connected to the Peplink, so I connected to the Peplink directly via Ethernet and it worked.

Today I went to connect and again it doesn’t work. It connects but no web traffic works on it. I’m plugged directly into the Peplink via Ethernet as well so definitely no Google Wifi here. Most my settings are default, but do I need to enable anything to have VPN work?

I’d also like to know this for in general as some of my customers want to use Peplink from us for fail over, but they need their Cisco firewall to still do VPN back to their head office so want to make sure I don’t have these issues. Thanks!

Do you have the HTTPS persistence rule running in the outbound policy, some SSL connections will break if a load balancer tries to split comms up across different connections.

Its usually a default on most Peplink devices I’ve seen

1 Like

Yeah I do have that on, should I disable it?

It wouldnt hurt to try removing the rule for the moment and see if it helps as its easy to recreate.

Normally this rule you’d always want in by default but recently it did cause me an issue with HTTPS/SSL sites but this was purely because the customer had their own load balancer behind the Peplink Balance which was terminating speedfusion tunnels, having their LB in path with this rule broke most of their HTTPS based apps.

It is the one and only time I’ve had to remove that rule but it wont hurt to test it and see if removing it makes any difference to your issue.

1 Like