OpenSSL CVE-2014-0224


#1

Is the Peplink Balance 380 vulnerable to the below? Does your firmware use OpenSSL? If so, what version of OpenSSL does the latest firmware use? **CVE-2014-0224:5th June 2014
**
Ref: http://www.openssl.org/news/vulnerabilities.html

"An attacker can force the use of weak keying material in OpenSSL SSL/TLS clients and servers. This can be exploited by a Man-in-the-middle (MITM) attack where the attacker can decrypt and modify traffic from the attacked client and server. (original advisory). Reported by KIKUCHI Masashi (Lepidum Co. Ltd.).

Fixed in OpenSSL 1.0.1h (Affected 1.0.1g, 1.0.1f, 1.0.1e, 1.0.1d, 1.0.1c, 1.0.1b, 1.0.1a, 1.0.1)
Fixed in OpenSSL 1.0.0m (Affected 1.0.0l, 1.0.0k, 1.0.0j, 1.0.0i, 1.0.0g, 1.0.0f, 1.0.0e, 1.0.0d, 1.0.0c, 1.0.0b, 1.0.0a, 1.0.0)
Fixed in OpenSSL 0.9.8za (Affected 0.9.8y, 0.9.8x, 0.9.8w, 0.9.8v, 0.9.8u, 0.9.8t, 0.9.8s, 0.9.8r, 0.9.8q, 0.9.8p, 0.9.8o, 0.9.8n, 0.9.8m, 0.9.8l, 0.9.8k, 0.9.8j, 0.9.8i, 0.9.8h, 0.9.8g, 0.9.8f, 0.9.8e, 0.9.8d, 0.9.8c, 0.9.8b, 0.9.8a, 0.9.8)"


#2

Peplink is aware of the issue and had been working on a fix. The 6.1.2 open beta has already included the fix. We will discuss in more details when 6.1.2 hits GA.


#3

OK, thanks Keith.