Open VPN client error "TLS Error: TLS key negotiation failed"

Got a couple clients where OpenVPN is not working. One is a first time VPN setup, the other one has existing VPN that had worked in the past but stopped working a few days ago. Both are Windows 10 clients with the latest OpenVPN 2.5 community VPN client. Both are Balance 20 routers with latest 8.1 firmware.

The client will not connect. I’m setup with split tunnel. I get a 60 second time out. I’ve tried on both port 1194 (default) and switching to 443. Same results. Any ideas?

Were you able to get around this? I was going to post the same message as you, but i figure if you didn’t get any help, i wouldn’t either.
i’m running 8.1.2 HD Max. I shutdown my firewall on the client to exclude that. Like you i get.

"TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Sat May 22 20:23:15 2021 TLS Error: TLS handshake failed
Sat May 22 20:23:15 2021 SIGUSR1[soft,tls-error] received, process restarting

I had forgotten about this and I am not sure I remember right now. I do know in one situation is was our in house router causing the issue. I had been trying to connect from my own LAN to the client’s LAN. But it seems there was more than one time and I will have to see if I can remember what it was. I did not get any response here as you obviously pointed out.