Open NAT


#1

I am probably not a typical Balance 20 buyer but I bought a Balance 20 for my home simply to get myself more downstream bandwidth and to ensure reliability (DSL 5mb/512k and Wireless point to point 6mb/3mb)

I worked great but my Bittorrent client (used legally!) and my PS3 both hate the Balance. The PS3 lists the NAT as STRICT and enabling or disabling UPNP and NAT-PMP doesn’t change anything, it still lists it as Strict, though I seem to have fewer speed issues when I have both turned off.

The bit torrent client won’t connect at all. (MacOS 10.7, Transmission as BT client) whereas it worked fine before (iMac to Airport dual band, to Balance 20)

Thoughts? Help?


#2

Hi There,

Thanks for the information. Just to eliminate some of the basic troubleshooting steps, I do want to make sure that you are up to date on firmware for the Balance 20. You can get up to date by using the Balance’s built in firmware checker under System > Firmware > Firmware Update. Version 5.3.9 is the latest release currently. Also to help ensure routing you may want to setup an Outbound Policy (Network > Outbound Policy–make sure that you are set to manage by custom rules) for your PS3 using it’s IP as the source and destination of any using the Priority Algorithm to tie the traffic to the particular WAN until it goes down and then it would failover to the secondary WAN.

If those steps don’t work, go ahead and open a support ticket with us at the following link-

http://www.peplink.com/contact/support/

Please capture a diagnostic report from the Balance while the issues are occurring and send it to us for review. Please make sure to get the reporting before rebooting the Balance to preserve the Event Logs for review. Instructions on capturing the report of course can be found at the
following link:

Ideally with the additional information we can find out more of what might be going on. Thank you for your patience in this matter.


#3

I am getting the same issue with my new Balance 20. Before installing, I was getting NAT Type of Open on the PS3. After, it went to Moderate. I’ve done everything you mentioned above. I’ve also forwarded all of the ports used by the PS3 online system to the IP address of the PS3 and setup a NAT Rule for it. I’m connecting to a single WAN connection (DSL modem) for now. Have another line being installed next week which is why I bought the Balance 20. I have the connection mode for WAN1 set to DHCP and routing mode set to NAT. I even put the PS3 IP address in a DMZ on the DSL modem.

Please help. Not sure why Open is so important on the PS3, but evidently it is (according to my son)…

Thanks,
Mark


#4

Hi Mark,

Since your DSL modem is operating as a router itself and then you add the Balance router, you are now double-NATing and the PS3 will not like this. Your problem will disappear if you put the DSL modem into bridge mode so it will pass a public IP to the Balances WAN port. Your ISP will help you with this.

Thanks,
Tim


#5

Hi Tim,

That worked! I set the modem to bridge mode and connected from the Balance using PPPoE. Now I’m getting NAT type of Open on the PS3.

Next question is how to connect back to the modem from the LAN with this configuration. I can get to it with a separate cable directly to my laptop, but not through the LAN.

Also, I just have one of the DSL lines setup this way. I’m forcing the PS3 and associated ports to WAN2 using a NAT Mapping and Outbound Policies. If I setup both modems with bridge mode, I assume that I would change the Outbound Policies from Enforced: WAN2 to Persistent. Is that correct?

Thanks for your help.
Mark


#6

Hi Mark,

Good deal, glad it worked :slight_smile:

Actually, there should be no need to connect to the DSL modem itself from the LAN when it is in bridge mode because it is only passing packets. The Balance router is handling the PPPoE authentication and all routing functions, so the DSL modem is just a “conduit” between the Peplink and the ISP network.

I recommend to set up your other modem in bridge mode as well. I have never had to use a NAT mapping or custom outbound rules for the PS3 at my house, it just works! I believe the PSN traffic uses https anyways, so the default persistent rule will take care of this.

Happy gaming!

Tim


#7

When I used a Balance 20 for my primary I never had any Nat related issues. Tim’s right, if the modem is acting as a router then you’ll end up with a double Nat issue causing issues on the router. I’m currently running off a Pepwave Max 700 and for my gaming rules I’ve got a policy setup under the firewall with both inbound/outbound connections to the consoles set to allow any port (basically a DMZ) with DHCP reservations.


#8

Everything is working great with the setup suggested by Tim. I have both modems in bridge mode now. Everything else is in default mode except that UPnP and NAT-PMP are enabled. I get a NAT type of Open on the PS3 and everything else on the network is working great. I’m really liking the Balance 20. Now if I could just get my ISP to give me 20M service, life would be great :slight_smile: Thanks for your help.

Mark