One-Way Audio on Soho Surf

Hi All,

I’m new to the Peplink community, but I’m excited to learn. I’ve grabbed 3 Soho Surf’s to start cutting my teeth on.

After playing around with these for awhile, I think I have most of the basics figured out. I’d like to start deploying these in some of my small business customers that will be doing a wide range of things, one of them being handle their voip, which is a cloud-based PBX.

In my initial trials, things seemed to go well. But yesterday I deployed one in a customer’s store as a test site. Prior to deployment, they were using a Linksys router, and everything else was already in place, including their voip system. The only thing I replaced was the router, which I swapped in one of my Soho Surf’s.

As soon as I threw in the Soho Surf, I started having one-way audio issues, and only on outbound calls. Inbound calls worked fine. On an outbound call (and it is every outbound call) the caller can not hear anything, including the ringing while placing the call. The callee can hear the audio just fine.

I will note that in searching the web, including this forum, I found several mentions to make sure to go to the Advanced --> Service Passthrough --> SIP and set the selection to Compatibility Mode, which I had already done.

So, again, I’m sure it is something within the Soho Surf settings, because as soon as I swap out the Soho Surf and replace the Linksys router, everything works fine. I made the swap several times just to be sure.

I’m sure it is something simple, but I just can’t find it. I know there is probably much more information I need to provide about my current setup, but being a newbie, I’m not sure what information would be helpful here. So if someone can help, I’m more than happy to provide whatever additional information I can to help. I’ll also list relevant information about my system below that I’m sure people who help will want to know.

Thanks in advance for your help and patience.

Thanks,

Phil

System Information:
Model: Pepwave Surf SOHO MK3
Firmware: 8.0.0 build 1429

Fault finding VoIP is one of my very least favorite things - I’d rather be fixing printer paper jams :slight_smile:
The best way to do this is to run a network capture on the SoHo, make an outbound call that then gets captured and then analyse the VoIP call SIP / RTP traffic with wireshark to work out whats going on.

3 Likes

This is almost certainly a firewall issue. The SIP connection is carried over ports 5060-5063. The audio stream is RTP on ports 10,000-20,000. You said “On an outbound call … the caller can not hear anything.” That means your inbound firewall blocking 10,000-20,000. What is the default setting on your inbound firewall?

Are these individual phones being registered in a remote cloud based server?

2 Likes

Sorry for the delayed response. We had to pull the Pepwave out for unrelated reasons for awhile.

Anyway, it’s a pretty complicated setup overall, but we simplified it to try to isolate the problem. We currently have an analog ata behind the SOHO that is registering to a remote cloud-based pbx. The strange thing is that it appears to work for a while, then after a time (sometimes days) it starts to exhibit this behavior. It’s almost like the router is “learning” something and adjusting. This isn’t possible is it?

I’m new to the SOHO, so I’m not sure where any settings are really. I’ve pretty much left everything I can as the default. Especially related to the firewall portion. Where do I need to go to check the inbound firewall rules related to 10,000-20,000?

Thanks again for your responses.

So, here is some additional information that may affect answers.

For our main WAN connection, we are connected to CenturyLink. We are not using their modem, we have their ethernet cable connected directly to the WAN port.

We also have a WiFi WAN on 5G connection set up. We are connected to the neighbor’s WiFi. They also happen to be using CenturyLink as their provider, but I know nothing about their setup. They just gave us their guest WiFi password.

So, if i set our SOHO to use the WAN connection as Priority 1, and the WiFi WAN on 5G as Priority 2 in backup mode, we get the one-way audio issue on outbound calls. But if I swap the two, putting the WiFi WAN on 5G in Priority 1 and WAN in Priority 2 in backup mode, the issue goes away. I don’t change anything else, including firewall settings.

So what’s different about WAN vs WiFi WAN on 5G? Any suggestions? I’m assuming that by default both use the same firewall settings within the SOHO. But maybe that’s not true.

Any ideas?

Thanks

Blockquote

This sounds more like the SIP connection is using one WAN and the RTP audio is using the other. When you set Priority routing the connection does not actually flip to the Priority source unless you check the box that says “terminate”. I think your RTP stream was using the Wifi WAN all the time, so when you switched SIP to 5G they did not match.

I suggest you change the Priority routing to Enforced and test again. If that fixes the problem you can then write a rule that says all traffic to your cloud based phone provider would be Enforced to the WiFI WAN without affecting your other traffic.

1 Like

I can see that would be a problem Haha…

So, again, being new to the SOHO, where is this checkbox for “terminate”?

I’ve been looking in what appears to be the user manual for the SOHO Surf, and they only place I can see “enforced” in the manual is relating to PEPvpn. I’m not using PEPvpn I don’t think. I literally pulled this out of the box, set up my WAN connection, set up my WiFi5G connection, set up my internal network and wifi ssid, and turned it loose. I haven’t done anything to firewall settings or anything. We were having problems with our WAN isp staying up (their problem, not the router) when we installed, so I switched the priority to the WiFi5G WAN from the beginning (VOIP worked fine). As soon as the isp said their connection was stable, I switched the priority to WAN as #1 and WiFi5G as priority #2. Audio problems started immediately. Switched priority back, and problem went away. So I think what you are saying is probably true. Not everything is switching with the priority. But I don’t see where to do what you are suggesting.

You need to add an outbound policy rule.

Destination = your cloud server’s IP address
Algorithm = Priority
Priority Order = whichever WAN you want to use as primary
a the bottom check the box for “terminate sessions on link recovery”

Rules are applied from the top of the tree and then down, with the first matching rule being applied. This is probably your first rule so it should appear at the top but if necessary you can drag it to the top by pulling on the dots to the left of the rule name.

With this rule all traffic to your cloud server will go out through the primary WAN unless that WAN is down. The selection for “terminate sessions on link recovery” means that when the WAN is restored, traffic immediately follows the rule even if that means temporarily breaking an active connection. If you don’t check that box, then you don’t know for sure which way the traffic will flow. That can lead to different pieces (ports) of your traffic to the same server going out different WAN sources.

2 Likes

So, just to be clear, in the SOHO Surf router web interface, I need to go to the ADVANCED tab and click on ACCESS RULES in the left panel under FIREWALL. Then add an outbound policy as follows:

But when I go to the outbound policy rule, I don’t see the Algorithm, Priority Order, or the checkbox for “terminate sessions on link recovery”.

Am I just not in the correct place?

The algorithy is Priority. After you select Priority the option for “terminate sessions on link recovery” will appear.

1 Like

When I click on “Add New” button to add a new outbound firewall rule, I don’t get an option to set the algorithm. I’m attaching a screenshot of the page I get when I click on the “Add New” button for the outbound firewall rules.

Ah now the plot unfolds. You’re in the wrong section. You be in Network > Outbound Policy. You’re telling the device where to send outbound traffic that meets criteria that you design.

1 Like

So, where do I need to be to do what you are suggesting?

There is no Outbound Policy on the Surf Soho. It is designed for WAN failover. Your requirement can be achieved by using Balance router .

1 Like