Not able to set IPsec VPN between Peplink 580 and Netgear SRX5308...help!


#1

We have spend two days trying to setup an IPsec connection between a Peplink 580 and a Netgear Router SRX5308 with no luck. These are the things we have tried:

  1. Verify that Phase1 and Phase2 encryption algorithms match.
  2. Verify preshared key match, even at the beginning we had a preshared key containing symbols like ^, @, $. We removed them and we try just a simple plain preshared key.
  3. Verify and match that the SA Lifetimes match for both phases in both sites.

Weird things we noticed are the following:

  1. On the Peplinkm the IPsec VPN status shows a spinning wheel with 100.x.x.0/24 <-> 192.x.x.0/24, but the VPN connection profile shows for the “Local Networks” setting 100.x.x.10/24.
  2. Unfortunately the Peplink does not have good logs!!!..we tried to troubleshoot based on the logs of the Netgear Router which showed the following line indicating a mismatch… [IKE] ignore information due to hash length mismatch_

Is there anything else to be done in the Peplink to make it work…?

Thanks!


#2

The IPsec feature in the Balance only supports connections to Cisco, Juniper, Peplink, or Pepwave devices.


#3

So there is no way to set a Site-to-Site VPN to a Netgear device from our Peplink?!!!


#4

We only officially support IPsec with the above mentioned devices, but many customers have been successful getting it to work with other devices.

Maybe someone who has gotten it to work with a Netgear can chime in here…