Non-NAT connection


#1

I currently have a Balance 30 with two Internet connections.

My ADSL connection is via a Netgear DG834G configured as a modem (it being one of the few ADSL routers which can be reconfigured as a ‘true’ modem).

My Tooway satellite service also has a modem (not router), so presents my public IP to the Balance 30.

This means that I don’t have any double-NAT since the Balance 30 is the only unit doing NAT.

My problem is that in the near future I hope to move to a new Wi-Max service in my area. They will provide a managed router and as such will provide me with a private IP address (they’ll be doing NAT in their box).

So I don’t want double NAT, I will want to connect this router to the Balance 30 but not have the B30 do NAT for this connection (i.e. just route between this WAN interface and my LAN).

Is this doable?


#2

You will just need to do a double NAT for this connection, and make sure the LAN IP subnet on the Balance is not the same as that coming from the WiMAX router.


#3

Thanks for your thoughts Tim but that’s what I want to avoid.


#4

Yes, I know where you are coming from :). Of course the double NAT is no big deal for outbound stuff like web browsing and downloading, but if you want to access services on your LAN coming inbound from this connection, it gets trickier. You would need to set up port forwards on both routers.

Anyways, my guess is that they will not give you access to their router and they will block most incoming traffic anyways - especially port 80.


#5

Double-NAT can cause certainly cause problems, hence the desire to not have it.
The Wi-Max provider I hope to move to will be providing me with a raw connection and hence allow fully-open both-way connectivity (i.e. no ports blocked).

Can this functionality be added as a feature request please?


#6

Can this be considered as a new feature?


#7

You can configure the WAN interface to IP forwarding mode in order to disable the NAT. But you have to create a static route on router in front of the WAN. To turn on IP Forwarding mode on Peplink, please click the “?” icon next to “Routing Mode” on the WAN Interface page, and you can find a link to turn on IP Forwarding.

For example:
LAN subnet of Peplink is 192.168.1.0/24
WAN3 obtained the IP (192.168.254.10) and the WiMAX router is 192.168.254.1.

You have to access the management interface of WiMAX router 192.168.254.1 and add the Static Route 192.168.1.0/24 via 192.168.254.10


#8

Ah excellent, I missed that hidden option.