New to pepwave, struggling to setup email notifications

As the title suggests, I am unable to get any response from my Cat18 Max Transit’s email test other than “test failed”

I am clueless where the problem might even begin because I do not see “test results” type logging like I see in some of the forum posts. Don’t know if the authentication is bad or if I’m even connecting to smtp servers. I tried turning on debug mode in CLI but this did not spit out any information when I attempted the test email.

I tried:
(1) adding firewall rules for 465/587 ports.
(2) setting gmail “less safe apps”, then moved on to try other (non-google) smtp servers.
(3) every conceivable permutation of (starttls/ssl/tls/465/587/save/test) options

Let me know if there is something basic I am missing or if I need to open a ticket. Thanks in advance.

What firmware version are you on?
Also I do all my email notifications with InControl2 now - never on the device, so that’s worth looking at.

1 Like

I am using the latest 8.1.0 b. 4929. I did not try to set the email notifications with the previous builds, so I have no basis for comparison.

As I said, I am new to pepwave, so if I can’t get a simple function like email notifications to work I would not be interested in increasing complexity with other services.

Hi @MobileHopeful. Your situation is curious. We have a l-o-t of Peplink/Pepwave devices out there and I’d say the majority are set up to send e-mails via the device’s web UI. (We never use InControl, although @MartinLangmaid describes a great way to do it. You don’t have to increase complexity, as you say.) When I think back to the times it did not work the problem was always caused by improper entry of SMTP parameters – server, port, etc. (usually a “fat finger” problem. :wink:) Can you confirm that the exact parameters you entered worked with an e-mail client? I.e., can you send e-mail from a “regular” e-mail account?

This will work. Let’s just spend a few minutes trouble-shooting it.

1 Like

Ok, I was finally able to find a work-around. While I never got gmail to authenticate, I was able to signup for yet another (about the 6th service I tried) email to get working. I suppose it is good practice to have a dedicated email for gateway events.

I ended up running manual telnet sessions to each of these smtp servers to try to get clues as to what they wanted. For some reason, I am unable to to connect on port 465 anywhere (at least from my PC on the pepwave LAN). I still have no idea if the pepwave device is better able to connect as it does not have a telnet utility for troubleshooting AFAIK. Feature request?

But many thanks for the hint, Rick, as when I saw I could not connect through a basic third-party email client - i knew something was not behaving correctly.

Just in case you are not aware of it there is a per network interface packet logging feature available through support.cgi but is limited locally to 20 M. As far as I remember the last time I used this I was able to open the log so created in WireShark.

1 Like

As @hcg has suggested, if you really want to troubleshoot this, the next step would be to look for this option …
at . (Obviously, substitute your device’s LAN address for the one I’ve shown.)

I might mention one other idea. Peplink has an excellent (and free!) iOS utility one can use to monitor Peplink devices – and get push notifications. It’s called “Router Utility” and available from the “app” store. We use it extensively and also recommend our customers consider it. It “just works.” .