New Balance 20x will not talk to Netgear cable modem

A new Balance 20x running firmware 8.1.0 build 4938 runs just fine with its WAN port connected to the LAN port of an existing router. However, when the Balance 20x is put directly online, it will not talk to a Netgear CM600 cable modem (Firmware Version V1.01.14).

I tried powering on the router with the modem running and the reverse (powering on the modem with the router running). Both failed. Also tried firmware 8.0.2 with no luck.

Had very similar problem with a Surf SOHO MK3 and the same modem. Surf SOHO runs fine on firmware 7.1.2 but firmware 8 would not talk to the modem. I connected a Chromebook directly to the modem and it worked fine.

So, seems like firmware 8 is the problem. It starts to connect to the modem, but then the DNS Health Check fails. Will open a ticket…

If you disable health check do you have connectivity?

Excellent idea! I did not think of that. Will test …

Tim - your idea fixed half the problem, so thanks again.

The Balance 20x running fw 8.1 will connect to the modem when WAN Health Checking is disabled. Enabling Health Check afterwards shows all goodness.

However, the same trick does not work on a Surf SOHO MK3 with firmware 8.1. The same Surf SOHO connects to the modem just fine with firmware 7.1.2 and Health Checking enabled.

On to the ticket…

I think there are bigger problems here than just your modem.

My B20x has crashed 3 times in a week. Got special firmware from support and it just crashed again.

Both status lights are green. Wifi not broadcasting and Ethernet not handing out an ip.

Will have to hard reboot and download a diagnostic report to send to support.

I’m not too keen on running on fw 8.1.0 right now.

@Michael234, we picked the ticket and will follow up with you there.

@stego, mind to share your ticket number for me to take a look?


Thanks @TK_Liew

We will follow-up the ticket and investigate further for the issue.

Similar problems with other Balance models were solved by putting a switch between the router and the modem.

Thanks, I remember those problems well. Not yet sure this is the same thing. Still investigating…