Never been able to log into inControl2

I finally set up my Surf Soho a few months back and it has worked fine even though when setting it up, I have never been able to use InControl2. I tried logging into it again last night but I still can’t log in. I’ve never logged in but it seems like it was set up because the App asks for user name and password. I’m wondering if I’ve been hacked. Last night I lost my internet connection to my tv and haven’t been able to resolve this issue using InControl. When using other software (Fing) it just appeared odd

Hi Welcome to the forum!
Pop along to and sign up there. It will ask you to create an organisation and then a group to put your device into then you type in your device serial to add it and you’ll be able to manage the SOHO from there afterwards.

Shout if you have any issues.


I have a SURF SOHO but I never signed up for IC2 when I bought it 2 years ago. I was kinda thinking it would be nice to be able to do the country block thing. Do I still get a free trial?

Hello @happysurfer,
If your device is out of warranty, you will not be able to manage it from InControl2.
Contact your authorise Local Peplink Partner for options on returning the device to warranty or if an InControl2 only subscription is available (subscriptions are not available for all models).
Happy to Help,
Marcus :slight_smile: