Need help : PepwaveSurf SOHO Novatel 620L

I have a problem with my PepwaveSOHO router. The problem is that my Novatel 620L USB modem will not “connect”. It initializes and then just “spins” at saying “connecting…”
The Novatel works fine when plugged directly into my laptop. I also have a Pantech 290 with a different SIM that will work just fine in the Pepwave. The Novatel worked for about a week and then started giving the above symptoms. The pantech has always worked.
THe pantech is my “old” setup. The Novatel (with a differnet SIM) is the new setup I’m trying to get to work again.
Initially, I had to upgrade the firmware in the Pepwave in order to get the Novatel to work. The Pepwave is now running the 8.0.0 firmware.
One thing is that different between the routers s that with the Pantech I can set the modem setting to “auto” and it will recognize the correct APN. For the NOvatel I have to manually enter the correct APN. Also, I can’t get the “new” SIM (in the Novatel) to work in the Pantech. Can’t try the other way around because the Pantech SIM is full size and won’t fit in the Novatel.

Any ideas why it worked for a week and now won’t?


For USB connection issue, please open a support ticket for support team to check. Detail info, please refer the the URL below :heart:

1 Like