My SIM seems to have changed carriers for no known reason

I’ve worked with enterprise routers for years, but have no experience with cellular.
Got my new MAX Transit 5G a few weeks ago and it’s been running great on AT&T.
Yesterday, the cellular WAN connection went down and it connected to my secondary with Comcast that I haven’t given up yet.
Troubleshooting the issue with the carrier, we discovered that the SIM is now trying to connect to T-Mobile instead of AT&T.
Couple of questions here…
How does a SIM determine which carrier to connect to>
And, how can it change that on it’s own?

Any help would be appreciated.
I have a definite learning curve ahead of me.

1 Like

What firmware version are you running?
What carrier is the sim?
Is it an ATT sim or some other company if so what company?
What plan are you on?
Was it showing 5G or LTE or LTE-A when you were connected?
Did it say data roaming?

Yesterday, the cellular WAN connection went down and it connected to my secondary with Comcast that I haven’t given up yet.
Troubleshooting the issue with the carrier, we discovered that the SIM is now trying to connect to T-Mobile instead of AT&T.

Hmmm. FWIW: In our neighborhood in Yosemite TMO went off the air from 1 AM to (approx.) 3 PM, PST. When TMO came back up, some of the devices reported that they were (successfully) connected to AT&T. A bit later, they changed their mind and reported the connections as being the expected TMO.

We did not have the time to check whether the AT&T connections were truly AT&T or alternatively TMO connections mis-reporting as being AT&T.

The SIM cards were all native TMO cards.



Update this morning…
Checking the details on the dashboard this morning, it showed the carrier as AT&T as it should, but still wasn’t connecting. I went to system and did a reboot. Going back to details, I found that it was then showing T-Mobile again.
What the heck?
This is weird.

The SIM card is AT&T provided by Mobile Must Have with the Bluebird data plan.
The Bluebird plan is a third party AT&T data plan limited to 500GB.
Showed as LTE connection.
I didn’t see anything to indicate roaming.
Firmware is 8.1.3

Your 5G device may lack these controls, however some suggestions to prevent carrier changes…

On the cellular wan setup tab
“Network mode” AUTO | GENERIC | ATT | VERIZON | TMOBILE - set that to “ATT”
“Carrier selection” default is AUTO - hard code that to the ATT carrier signal/number

Good point Eric, I think some controls were added in 8.2b01.
According to this post:
You can try running the 8.2b01 firmware for the Max transit.

Current update…

The 3rd party reseller has now been radio silent since Friday and appears to have no interest in helping me resolve this.

I went to AT&T today to inquire about their 100MB/$55 data only plan. The salesman wanted to upsell me to a pre-paid $65/Unlimited data only plan. He assured me that it works, is not throttled, and is what he uses in his Netgear router.

I decided to give it a shot. What am I out if it doesn’t work, right? I paid for the plan, got the SIM, and took it home and put it in slot B in my router. (After receiving emails from AT&T about my new account, I discovered that he has sold me a business account. Not the end of the world, but not what I was asking for. I try to do things properly when I can and I’m not a business.)

When the SIM came up, I noted that it also showed the APN as “” the same as the other one did. I changed the APN to “broadband” and the new connection came online. It even shows to be connected at 5G.
Carrier : AT&T
Country: United States
Network: 5G NSA
5G Band: 5G Band n5 (850 MHz)
LTE Band: LTE Band 66 (AMS 1700/2100 MHz)

Because of things I’ve read while doing the research to figure out how to resolve my issue, I decided to give this connection a 250GB data cap for now. Speed tests showed Download at 54.1 Mbps & upload at 26.2Mbps. Video shows caped at 1080p. I can certainly live with those results. We’ll see what it does when we go on the road to Arizona next month.

I’ll wait until the pre-paid month on the 3rd party resellers plan is up, but then I think I will be removing their sim and not moving forward with creating a payment plan for them. I have not been impressed with them.

I’ll continue to update this as time goes forward. This has been strange to say the least.

It probably isn’t throttled but is deprioritized after a certain GB.

What is the exact name of the plan the salesperson gave you?

Very curious what this $65 att data plan is too.

Please let us know what plan it is. Is there a name on the receipt / invoice or something?

The thing is, there is no such unlimited prepaid data only plan for $65. If there was then the likes of Mobile Internet Resource Center would be all over it, shady resellers would be out of business and the challenge of getting high volume plans for routers would be solved.

I’m not doubting what you’re saying as to what happened at the store but I don’t know what plan you were really sold. AT&T has a prepaid unlimited phone plan for $65 ($50 with auto-pay) which probably works (until it doesn’t) so maybe it’s that.

I’ll be very happy to be proved wrong and there is a secret plan that none of us have heard of.

EDIT: Sorry I missed that you answered the question in your post. It’s a business account. I suspected that at first but I didn’t think there was prepaid for business. I thought business was all postpaid.

1 Like

I’m having a hard time sorting that information out.
The email calls it “Business Agreement version 12-B”.

On a further note, I did finally hear back from the 3rd party seller this morning.
They are saying that they think I’m in an area that doesn’t have any AT&T service.
I gave them my address here in the Greater Seattle area and the connection data from the router on the new SIM.

I’m interested to hear what they say next.

The 3rd party reseller had me swap the SIMS in the router. The issue moved, as I expected it would. I had already planned on doing this, so at least their troubleshooting practices follow mine.
Now they have asked me to go out and purchase a new SIM card and send them the info for it.
Funny, since when I asked if it could be a bad SIM card, they responded that it’s not likely to be the SIM card.
This troubleshooting by email is driving me crazy. I’m a high-performance individual and work for a high-performance organization that deals with public safety (specifically traffic signals). We would never have this type of nonchalant troubleshooting style. Even the outside plant fiber I manage carries customers that are hospitals and colleges. Our restoration times are measured in minutes and hours, plus we respond 24/7. OK, enough of this. I’m starting to rant. Sorry.

As for the AT&T business plan, I’m guessing that it must be post-paid as there is no charge against my account yet.
I’m really conflicted about what to do about it. I really don’t like trying to cheat the system as I always seem to get burned when I do. The fact that it is a business account and the agreement I signed, I thought it was the receipt for the purchase, states that I certify that I am a business, when I am not, bothers me. I did think it was weird that I only had to sign once.
Also, weird that I can’t find anything but an agreement number. Nothing to use to administer an account with.

2-1/2 hours on the phone with AT&T today with 5 transfers, but I now know what I was sold on Sunday.

The salesman at the AT&T franchise store sold me…

(Dramatic drum roll)

…an unlimited business cell phone plan for me to use in my router.

That service has now been deactivated and I will receive no charges for it.
However, that being said, I also was told that the business account that was created will stay open for 30 days before closing automatically for no plans or equipment being on it.
If during those 30 days, I wish to, because I now already have a business account, I can purchase any of their legitimate business plans that will work with my router.
And I have an email link from the business agent that resolved my issue that I can use to take care of that without having to go into a store. He also sent me some links of the available plans to evaluate to see if they might work for us.
They actually were not concerned that I wasn’t a business so much as trying to figure out what I was sold because, as everyone has said, there is no data only plan that matches this.

All-in-all, I would say that this was a very successful day.
I feel much better having called and resolved what it was that I was sold. As I stated earlier, I try very hard to do everything above board and correct to the best of my ability.

I’ll continue to update this post as I go forward trying to troubleshoot the issue with the 3rd party reseller Bluebird data plan.
I’m curious to see if replacing the SIM card solves the issue.

Could the SIM information have accidentally been sent to another reseller that tried to activate it as well? What stops that from happening? What happens if 2 different entities try to activate the same SIM on 2 different networks/accounts?
Inquiring minds want to know.

1 Like

Replaced the SIM card and I am now back online.
I still think there is more to this than a 3-week-old SIM card randomly failing, but I doubt we will ever know what truly caused it.

I don’t expect to post anything more unless some form of additional data presents itself, or the issue repeats.