Multiple Issues soho mk3

[note, this was really meant as a review, figured i’d post here first and see if i got any help]
I really wanted this router to be excellent. The regular security updates and configuration options were major positives, but it’s not reliable enough. I’d rather have security than something that just works but it’s worth looking elsewhere. List of issues:

· Wifi connection drops
o Issue: Wifi connection lost
o Occurs: Random instances, usually reconnected.
o Root cause: likely firmware
o Discussion: this is an older issue, it hasn’t happened much of late and I don’t remember too many details. Most likely addressed with firmware updates. Mostly just an annoyance.

· Wifi internet access issues
o Issue: Wifi stays connected but internet access is lost
o Occurs: Often enough to be recurring but no regular event/cause yet identified
o Root cause: likely firmware, but possible the phone is the problem.
o Discussion: Appeared more recently, around when firmware was updated but isn’t definitively linked. Connection remains but routing table (or something) prevents access to internet until wifi is disconnected and reconnected. Again, mostly just an annoyance.

· Port speed mismatch issues
o Issue: data transfer between computers within the local LAN caps out at ~800kbps.
o Occurs: When Denon AVR is connected to the router (hardware speed limit of 100Mbps)
o Root cause: appears to be a port speed matching issue within the router?? Haven’t gotten beyond identifying as router issue and finding work-arounds.
o Discussion: The router can only set all four LAN ports together, they can’t be set individually. With port speeds set at Auto, the 2 computers and 1 AVR auto negotiate speed and the computers are at 1Gbps, the AVR maxed at 100Mbps. In this configuration, computer to computer traffic is sub 1Mbps. When set at auto and the Denon is unplugged or turned off (with network keep-alive disabled) computers run at full speed. When the Ports are manually assigned at 1Gbps, the Denon can’t get on and computers run at full speed. When ports are set at 100Mbps, all devices are on and computers work up to 100Mbps limits. Unsure if this was introduced with firmware update or was always there since I previously kept the AVR off the network.
o Notes: Other root causes that could possibly be causing issue have mostly been eliminated. Tested with AVR wired to a WIFI AP and connected to the internal network via WIFI (no issues, full speed). Internal firewall and outgoing firewall on the Denon modified to verify no impact to results. All Ethernet wiring temporarily changed to shorten lengths and verify no cable/interference issues, no impact on results.

· WAN connection issues
o Issue: Regular issues with router connecting to Cable modem
o Occurs: Usually after a power fluctuation or a router or modem restart.
o Root cause: Unknown, but this is a known problem around the net and some say it’s due to how tight the timing window on the WAN port is vs how loose some modems are.
o Discussion: This has been happening since day 1 and is probably my most common issue. The Router just can’t connect to the Modem and, so far, no amount of settings changes have permanently fixed this issue. Sometimes restarting both devices makes the connection, sometimes not. Sometimes you need to start one device before the other or vice versus to make the connection, sometimes that doesn’t work. When it has gotten really frustrating and plenty of time has been wasted, I resort to connecting an old router between the modem and the WAN and have it configured essentially as a pass through switch to make the connection. Once the connection is made it usually isn’t dropped unless power is lost or something restarts.

· Total failure of wired LAN
o Issue: Complete failure of all wired ports
o Occurs: 18 months after purchase, perpetual
o Root cause: POS router?
o Discussion: This is why I’m writing the review. A $200 router lasted under 2 years and it wasn’t even a good 18 months of use with all the issues above (of course the warranty is only 1 year). Firmware does not appear to be the issue as it hasn’t been changed in a month, a FW rollback doesn’t help, factory reset doesn’t help. I haven’t tried to further trace the issue this time, I’m on the verge of giving up. Every device previously working on wired LAN can no longer connect. IP’s do not get assigned and using static IPs doesn’t help things along. The DHCP server, and apparently everything else, is still working since wifi has no problems connecting and minor issues browsing (aside from those mentioned above). I’m now running computers as wireless devices and I have a significant amount of latency, more-so than ever before. Could be the 15 year old wifi dongles, possible. Could be the signal strength/interference, unlikely. Could be a router is on its last legs, possible. I haven’t yet contacted peplink because I expect my response will be: ‘sorry, out of warranty’

The features of this router were great when it worked… Could use my phone hotspot as WAN when Cox failed (somewhat often), internal/external firewalling, access controls, QoS, VLANs, multi-wifi… actual security updates.

EDIT: In re-reading this I should also clarify that, for the port speed mismatch issue, WAN speeds did not seem to be impacted when the AVR was connected. I say seems because i have fairly slow internet anyway.

1 Like

WOW!
That’s a lot of problems. You must have purchased the one that was dragged behind a truck.
I have been using the Surf soho for five years now and have had very little problem.
I would open it up and see if there’s a gremlins nest in there.

1 Like

Guess there’s no suggestions or help coming? :frowning:

Hi. Hmmm. Not sure, but I’d suspect you have not received an answer because (1) the narrative and problems are a bit overwhelming and (2) this experience is totally foreign to we Partners and SOHO users.

FWIW, I can tell you we have had experience with all three versions of SOHOs and have never run into the issues you describe. And, certainly not in that combination. Indeed we have original HW1 version SOHOs still in service and working splendidly. This is not to minimize the impact of your experience, however.

What does the Partner from whom you purchased the product say about these issues, I wonder?

1 Like

I guess I was mainly looking for advise on the Wired LAN failure more than anything else. I got it from 3gstore (now 5gstore) and their system doesnt seem to realize I purchased this - Even though i can go into historical orders and find it - meaning I cant get any of their ‘resources’ (for what they’re worth). Sent an email, not expecting too much - “We provide 1 year of free tech support” We’ll see.

Suggestion: Call them by phone.

1 Like

Update: contacted 5gstore, they had me download diagnostic file and submitted a ticket with peplink. Peplink asked if there was ever any tickets opened while under warranty (which there were not - early on, most of those issues seemed like firmware problems) and then closed the ticket without doing anything.