Mullvad OpenVPN setup (no support for custom port?)

Balance 580, upgraded to 8.1.1. I purchased the OpenVAN Wan license and installed it and have been attempting to get this to work with Mullvad VPN. It appears, however, that this firmware maybe doesn’t support a custom server port? Mullvad apparently uses custom ports, as seen in this snippet from their .ovpn file:

remote 1302
remote 1302
remote 1302
remote 1302
remote 1302

But the router shows it still trying to use port 1194. Even removing the port number from the server entries and adding a “port 1302” directive does not work.

If a custom OpenVPN port is supposed to be supported, please let me know what I can do to make that work. If it’s not supported, I sure hope you will be adding that very soon!



This is a web UI bug. The OpenVPN WAN will use the port according to the uploaded file. Please submit a ticket if you still not able to make the OpenVPN WAN connected.

Did you get Mullvad working?

I’m unable to get a connection. The error I receive is invalid OVPN file. I’ve tested the same file with an OpenVPN client separately and it works on the client.

No, I rolled back to 8.1.0 because the web content filter started classifying almost everything as “Social Media”, which really messed up some users.

@mscott Thank you for the reply. I haven’t got it working yet, but when I do, I’ll update the thread with my notes.

1 Like

Just to update, support has confirmed that the current OpenVPN support does not allow for the use of a custom port. It only works on port 1194. I don’t see an option with Mullvad to use this port, so it appears that for now we’re out of luck.

Thank you for investigating this. I was hoping that someone would find a way for it to work. Is Mullvad
not following a standard or convention by using a custom port? (I confess my knowledge of the OpenVPN standards, etc. is very limited.) Is there a list anywhere for what VPN services work with the OpenVPN? Perhaps it would work with a Wireguard implementation in the future.

@mscott, the problem you are facing is not related to the OpenVPN port. We notice Mullvad assigned IPv6 to the OpenVPN WAN. We provided a special firmware to you from the ticket. Do let us know how it goes and follow up with us in the ticket.


Yes, it appears that the initial information I received from support might have been incorrect. The good news is that firmware provided does allow for an OpenVPN connection to Mullvad! Woot!

I have the Surf SOHO 3. With the v8.1.1 firmware and the standard OpenVPN WAN firmware addition would I expect Mullvad to work with IPv4? And is there any additional configuration information that would be beneficial to make this work. My knowledge in this area is limited.

Hi @TK_Liew, is it possible to achieve this setup with Mullvad VPN as WAN without a custom firmware? I have the same issue.

The fix should be available in 9.0.0 and 9.0.0 is under development. We can provide special firmware if this is urgent.

Not urgent, I appreciate the reply. Looking forward to 9.0.0

If anyone has a problem to connect Mullvad, kindly upgrade your device to 8.4.1.

1 Like

Working great so far! Thanks so much!