More than 254 devices on LAN

My current LAN is Subnet What is the easiest and/or best way to increase the number of static and dhcp LAN clients?

I think I would consider two primary approaches:

  1. Extend the existing subnet
  2. Segregate the LAN with new subnets / vlans

**1. Extending the existing subnet. **
At the moment you have (a class C network). One approach would be to move to a class B network - so (a subnet mask of
This would give you 510 hosts for this subnet -

You could do this by updating your DHCP server and then manually updating the subnet masks of all the statically assigned devices. If you did the DHCP settings on a Friday evening, most devices would renew their DHCP leases by the monday morning so it would likely cause little disruption.

2. LAN/VLAN Segregation
If you have managed switches and routers in your infrastructure that support it, you could vlan off groups of devices (like printers, voip handsets, and servers) and put them into their own subnets with their own DHCP server ranges. LAN devices would then route to each other through a core Layer 3 device (potentially the Balance router you might have as the gateway - the balance can also provide the DHCP server service for each VLAN/Subnet).

If it was me, I’d likely just extend the subnet since thats the least disruptive way forwards, unless you can imagine yourself needing more than 510 hosts in the future, in which case LAN segregation is ultimately the right way to move forwards as you would otherwise be increasing the chance of broadcast storms having a detrimental affect on the network traffic.


I will extend the subnet. Most of the devices are DHCP so they will re-acquire. Of those that are currently on static devices, a few are managed by outside vendors so would be difficult to coordinate the change. Will they still be able to communicate? Example:

Balance 380 current LAN: / DHCP range 001 to 123.
Balance 380 change to / DHCP range 255 to 508.

An existing device is at /
Will that device still be able to communicate with the Balance 380? I understand the device won’t be able to communicate with devices higher than 254, but I believe it should still be ok without modification between the devices between 001 and 254. Other devices statically configured 254 or less could still communicate. Correct?

Related to the above example, can I build a LAN static route temporarily for that existing device to see the extended range subnet for those devices that currently do not have the expanded subnet? I am on version 6.2 firmware. Or would the router figure that out on its own? To be clear:

Existing device at / Build a route to permit two way communication to another device on the LAN at /

Some of these vendor managed devices are very difficult to get changed.

You are right that devices within the original host range (from the /24 subnet) will be able to communicate with those that are within the same host range but now using the /23 subnet - so no changes required to the vendor managed equipment. However, devices in the /24 host range will not be able to route to devices in the extended /23 host range without a Layer 3 device in the middle.

BUT. So long as the gateway device (your balance 380 in this case) is using the new /23 subnet, devices configured with the old /24 (like those vendor devices) will be able to route to devices in the new /23 host range using the balance as the layer 3 intermediary. I have tested this on on B380 running 6.2.2 build 3362.

So change the LAN subnet on your Balance 380 to use the /23 subnet and everything will come right :slight_smile:

Original configuration, the router is 124 on the LAN. DHCP range 1 to 123. 125 to 254 used for static devices.

I changed the LAN on the B380 to / I also changed the DHCP subnet to When I tried to change the DHCP range to 255 to 508. I get an error message “dhcp range must be in the same network” I do not understand why that would be an error.

I then tried to change the DHCP range to 1 to 508. I get an error that the router’s IP cannot be within the DHCP range. That message I understand. I might have to move the IP of the router to 1 or 508 in order to use the entire range?

So your old range was That has a host range of .231.1 -> .231.254

If you change to a /23 you get a host range of 230.1 -> .231.254 (510 hosts)

You say your router is on .231.124, and the current DHCP range is .231.1 -> .231.123 (123 hosts)

So you need your new DHCP range to be .230.1 -> .231.123 (which gives you 377 DHCP host addresses)

This worked fine for me on my B380 see below:

Aha, now I understand. I thought it would be 231.1 to 231.508. Now I understand, its 230.1 to 231.254.

I have threre other Balance routers remotely connected to the unit above, via Speed Fusion. The other two found the expanded subnet and adjusted their settings all on their own. This is too cool! You make a great product.

Thanks Don :up:

This seems to be causing me problems with PPTP VPN. Original configuration LAN, I had no trouble connecting PPTP and accessing other devices. I had an inbound rule allow any source, any destination.

Since changing the LAN to, I also changed the inbound rule to permit the same source, allow any source, any destination.

Unfortunately I am unable to communicate with any LAN devices. The PPTP connection is there but no communication. From the remote device you can’t even ping the Balance LAN address itself. No reply.

I tried adding an inbound rule to permit any/any from That did not help.

Well… it appears I spoke too soon. I seem to have a limitation of bug with the PPTP server. Since changing the LAN to /23, the PPTP server connects but cannot communicate with anything. It can’t even ping the router that is providing PPTP.

I want to use for DHCP and for static devics. I think thats where the problem starts. I set up the DHCP server for: - /

The router is I think the problem is that by specifying the .230.0/23 range, I am telling the dhcp server that its ok to talk to 229 and 230, not 230 and 231. It may be the only solution is to reverse the configuration so that the 231 range is dhcp.

Is there a different subnet other than that will allow me to start in 230 but also go up into 231?

Hi Don,

IP range for = -
IP range for = -

So is part of IP subnet 198.42.229.x is fallen in another subnet which totally can’t communicate with or You may refer here to do IP subnet calculation.

Please ensure all hosts in your LAN changed the subnet to Else you will face communication problem.

Another question, why you are using public IP in your LAN environment?

RE the public IP, yes I am aware of that. I inherited it from a vendor who set it up 20 years ago. At this point it would be too difficult to change, seems to work ok.

All our LAN devices are changed to Almost all are getting their IP via DHCP from the Balance 380. Those with reservations are in the 231 range. Those without reservations are getting addresses in the 230.1 - 230.254 range.

Let me restate my question differently. With subnet, I have the 500 IPs required. All above works fine except for PPTP remote access. If I set the Balance DHCP range subnet mask to, the PPTP clients cannot communicate. As soon as I change the Balance DHCP server to, the PPTP clients come alive but of course then I lose the additional 254 IPs from the DHCP range.

It appears the PPTP server cannot work work with that subnet. Is that a known PPTP limitation or possibly something in the software that has not come up before?

Hi Don,

  1. May I know PPTP server is referring to the PPTP service on Balance router?

  2. May I know what firmware version you are using? If you are not using latest firmware version, please download here.

I did a testing on this (Assume my assumption in question 1 above is correct). It works as expected.

LAN Setup


I am using the Balance internal PPTP server, not a separate box. My setup is exactly as in your picture, my setup attached. Running 6.2.2, build 3362. I’ve been reluctant to upgrade to 6.3 due to some other threads here with issues. Was there something updated in 6.3 that might fix this?

If I change the DHCP range to - /, the PPTP server works.

If I change the DHCP range to - /, the PPTP server fails

If I change the DHCP range to - /, the PPTP server fails. Actually that makes some sense because that range is actually 229-230, not 230-231 as desired, correct?

Some other routers allow the PPTP server to reserve specific LAN IP addresses for the PPTP server. If I could do that, I could put the PPTP appearances exactly where I need them to be. It appears there is no way to do that on this system.

Web Admin.pdf (258 KB)

Hi Don,

I tested it was working fine in v6.2.2. Please find the screenshot below.

Have you work with any local Peplink partner? I think this problem can be solved quickly by having on-site support.

TK, this is working correctly for me now. I tried a different remote computer. I don’t know how but there must be something wrong with the original computer I was using to test. I greatly appreciate all the effort you put into testing.

Hi Don,

Glad to hear that you managed to solve the problem! :up: