max transit duo stuck "obtaining IP address" and Google support not supportive

RE: FCC Case #00026860 | [Peplink #22020882] SIM Card connectivity [ ref:_00D6A2zSvx._5003uoPrRE:ref ] Re max transit duo BF2D: AT&T Sim works perfect. Google Fi worked fine with previous account and now just stuck trying to obtain IP address. Firmware is current. Confirmed that SIM slots and different antenna connections all work. I’m convinced that this is not a hardware issue. Suggested APN (h2g2) and DNS settings (8.8.8.8 8.8.4.4) were tried and did not work. Shows IMSI (in use) and carrier as Google Fi. I am currently in a good known spot for connectivity (5 bars AT&T/ 4 bars Google Fi plus actual tests confirm both cellular transmissions are solid.) Google customer support has not been helpful. Thanks in advance for help anyone may have to offer. markb

Is it getting an ip address?
What color is the sim white or yellow?

Hi Mark,

You are correct in thinking it is not a hardware related issue. When it is stuck on obtaining IP address it means the SIM card is not able to authenticate to the network. The SIM card may not be active or something wrong with the account.

With Google-Fi you may just need to enable roaming and that may resolve your issue.

Cheers!

Thanks for the quick responses

The IP address and other associated items do not populate for the Google sim.

sim card color has a white surround

Enable roaming did not resolve the issue, but thanks for the try Tim.

thanks, markb