MAX Transit CAT18, not obtaining IP

I received my MAX Transit CAT18 a couple days ago. I put on the antennas and installed my T-Mobile sim card. I could never get it to obtain an IP address. I figured I would try an AT&T card, same problem persisted.

I have specified DNS manually, that didn’t work.
I have taken it to town and made sure that it isn’t just the tower in my area, that didn’t work.
I have called TMO and AT&T and given them the IMEI etc…
I have tried selecting single bands (ex only band 12, or band 2, band 71, etc…)

Does anyone have any ideas? I’ve checked for firmware updates, and cell modem updates on the support.cgi page, everything is up to date from what I can tell.

Any ideas would be greatly appreciated.

1 Like

I have a MAX Transit CAT18 and an HD1 Dome that both refuse to get an IP address from T-Mobile. I’m running 8.1.0 RC2. This worked before with earlier versions, same hardware on both the MAX Transit and HD1 Dome. I assumed it was because of the newer firmware, but perhaps it has something to do with the modem firmware? I’ve confirmed that if I put it in a non-Peplink device, it works just fine.

I also have an AT&T and Verizon SIM and they are both working, so perhaps your issue is something completely different if you’re having issues with both…

I have case 20070618 opened with Peplink but there hasn’t been a fix yet.

I just saw that 8.1.0 RC3 came out, so I am going to be upgrading here shortly to see if that helps.

What version are you running?


I am considering upgrading to a MAX Transit CAT 18 but I see that it still is not Verizon certified. I noticed that you said you have used a Verizon Sim in yours. Have you had in problems with Verizon. I have an active SIM that I am using. I have a MAX ENT that is new and is not working correctly and trying to decide whether it get another ENT or get the CAT 18. Thanks for any advice and info about the Verizon certification.

I have not had any issues with my Verizon SIM / plan in the MAX Transit CAT18. I’m actually using it right now to reply to your questoin :slight_smile:

@GTIChris04 I did determine that T-Mobile blocked the particular plan / line I was on from working on their network if using a CAT18 MAX Transit, specifically the type of modem included in it and other products.

Not sure if you got a resolution/answer on your question above, but that was it for me.

1 Like

I didn’t look closely at the brand/model of modem used in the Cat 18. Is it the brand of modem or the specific modem model that t-mobile has blocked?

And are you going to look for a different t-mobile plan that will work with the Cat18, or give up on t-mobile with it?

1 Like

I wrote up my experience and journey here. I don’t know that anyone but T-Mobile can 100% confirm what they’ve blocked, but it appears to be the brand and model of a specific modem.

I was forced to change my plan to a hotspot data-only plan at a much higher cost in order to get it to work. I also do not know whether they will severely rate limit me after 22GB of monthly data, and continue to test.

Thank you Steve. What antenna are you using with the MAX Transet?

1 Like

I found that if I change my TMO plan to a data only plan the CAT 18 works. However, I went through 2gb in about an hour with my nest camera and doing some work via VPN. I guess I’ll have to look else where for another plan.

Good info, thank you all. Has anyone tried the B310X on AT&T? I’m not having any luck with it and AT&T says the IMEI isn’t recognized…

I’m using two Poynting OMNI-402 antennas. I’ve also used the T-Mobile SIM in a CAT18 MAX HD1 Dome which has the same modems. Once I switched the “line” or plan to data-only I was fine.


I can confirm this new plan is not the same as the previous plan. Not only are they citing a higher cost, but it has a hard 22GB cap and then goes to 3G (unusable) speeds.

I’ve escalated this with my contact at T-Mobile - hopefully they can at least change the hard cap at 22GB - it originally was “unlimited” and didn’t slow down until 30-40GB a month and only in congested areas.

Hi Steve,

I got a MAX 18 and it is up and running on Verizon. So far so good. Thanks for the help!