Max Transit Cat-18 not working on T-Mobile

I have been using Verizon through the MVNO BJ Communications. It has worked great with my Max Transit Cat-18. I wanted to add some redundancy, so I got T-Mobile through B J Communications just recently. Bottom line, Verizon still works like a champ but T-Mobile does not.

Does anyone see a problem with my config? I have Verizon in SIM A and T-Mobile in SIM B and switch between them manually.

I had T-Mobile flying with auto for the APN. I use MTU of 1428 and TTL of 64. I also use OpenDNS DNS Servers.

Thanks, Chris! I’ll give it a shot.

That did not work, unfortunately.

What firmware are you running?

T-Mobile data plan or T-Mobile voice plan? It will not work with a voice plan.

Hi Chris. I was running 8.0.2.4407 and I upgraded to 8.1.2.5114 this morning as a part of my troubleshooting.

firmware

I have a 400GB T-Mobile data-only plan from the MVNO B J Communications. Their Verizon plans has worked well.

Do they have a custom apn you have to use?
Have you tried encrypting all the traffic, like sending all data over a pepvpn?

Hi Jonathan: yes, the custom APN I am using is…

fast.T-Mobile.com

I will try using a VPN! Thanks for the tip!

I ended up giving up on the B J Communications T-Mobile service on my Max Transit Cat-18. Tried all the suggestions from this forum and from the MVNO.

I just received my ATT SIM from BJC and it worked immediately and is blazingly fast.