MAX HD4 - Corrupt SD card? - advice needed please


I have an out of warranty MAX HD4 that is refusing to boot up. Peplink took me through various attempts to reset the unit, but it still has the same behavior. The power and status lights are permanently illuminated. The LAN ports flash about every 10 seconds and I can’t get a constant network connection.

Peplink has told me that it doesn’t sell parts or cards and that I need to buy a new unit so eventually I took it apart and checked it out.

After multiple checks and then some trial and error I suspect the SD card has failed or is corrupted. I believe that the SD card is the problem because if I boot the unit without the SD card present it will at least keep a steady network connection to a manually configured computer.

I’ve tried to clone the SD card but it looks like I have 2 files that are a problem.

Does anyone know what should be in 8.0_config and config? Also the respective file types?

If anyone has a cloned HD4 SD card or what I suspect are the 2 corrupted files then I’d be very interested to try it out.

Many thanks in advance.


have you get it solved?

No, not yet. Do you have any ideas for a potential solution?

Does this model have a console port?
You could attach to the console port and select the second boot firmware.

Hi Jonathan
Thanks for the idea. Unfortunately, I can’t find any reference to a console port for the MAX HD4.

Sorry I thought that model may have had a console port.

Hi David,

I made image file from Compact flash card out off a broken BPL-380 with firmware 6.3.4.
so i opened the image file and compared the config.1, config and 8.0_config and they are all the same.
So if you copy config.1 2 times and rename them to config and 8.0_config it might just work :slight_smile:

Let me know if it works.

Kind regards,

Dylan van Elst


Hi Dylan
Thank you very much for the idea. I’ll investigate and revert.
Kind regards

Hi again Dylan
I tried doing as you suggested but it didn’t make any difference. I suspect that my issue is in the 2 encrypted partitions. I guess these contain firmware and unit ID etc.

Hi David,

That’s unfortunate…
On firmware 6.3.4 you have a Boot, Firmware 1 data, Firmware 2 data, configs/logging and some Unallocated space.
I wasn’t able to find where the device id is stored. So maybe those are stored in the Kernel or Initrd boot files somehow. sadly I cant open them and they are probably encrypted…

I also created a image file from a HD2 SD card. Looking at the partitions I suspect that the firmware is stored in the encrypted partitions…

Maybe its possible to access the console using the pins on the motherboard?

Kind regards,

Dylan van Elst

1 Like

Thanks Dylan
I’ve attached 3 screenshots of the original SD card from our HD4:

  1. The partitions - sounds like we have the same structure
  2. Folders in partition dev/sdd5
  3. Files in partition dev/sdd5

Interestingly I don’t see a Boot file or folder. Do you have any further details?

Also, although there’s 66.20MiB used in partition sdd7, I don’t see any files or folders.

Trying to connect to the pins on the motherboard is probably going further than my expertise, but I guess that I could find a connector on amazon and make up a cable.

Thanks again for your efforts and ideas … I owe you regardless of whether or not I have a very expensive brick!


1 Like