Max HD2 cant connect to LAN devices

im quite new to networking, so sorry for that simple problem I have.

My PepVpn is established and I can ping the LAN and WAN IP of both MaxHD2 routers via the PepLink Ping tool.

But that only works if I select my PepVPN connection in the ping tool and I cant ping my fritzbox routers or any ip cameras.

If I select Wan or Lan as connection, I cant ping any device of the other side of the router.

I made partial success by setting a static route on MaxHD2 (upper one) with as Gateway.
Now I can ping fritzbox and IP Cameras via the PepVPN Connection tool.

But none of my Lan Clients of network can ping the other side.

I made a static route in fritzbox( to forward to Gateway, but no sucess.

Your topology is a little strange. Normally you would have LAN devices behind the HD2 on both networks, and those LAN networks would be ona different subnet to the WAN of the HD2. By having the same network on both LAN and WAN on the HD2s you’ve given yourself a headache.

Since you have no devices connected to the LAN of either HD2, one way to fix this would be to:

  1. Set IP forwarding on the WAN of both HD2s
  2. Give each HD2 a new (different) LAN subnet outside of the ranges currently in use (iw set one to and the other to
  3. In OSPF settings on both HD2s tell them to advertise their WAN networks.
  4. on each Fritzbox set a static route for the remote network to be teh WAN IP of their local HD2.

Then Traffic should route as expected.

1 Like

Thanks for your feedback, works perfect.

Currently I’m on vacation, and Im connected via HD2’s WIFI Wan to the router of my hostel, my notebook
is connected to LAN of my HD2 with a differnet subnet.

Internet works, but Pepfusion VPN to my remote side gets stuck at creating tunnels.

As I cant change the router’s configuration, is there still a possibilty to create a speedfusion VPN?

I switched over to my Vodafone Mobile Connection and deactivated my WIFi Wan.

Created a Speedfusion Vpn and entered the remote IP address of my home network. Home network is behind firewall, but Speedfusion ports are forwarded to my HD2.

VPN connection status is canceled after "Creating Tunnels"
Cellular connection shows “Detecting link status”, then “Link failure detected”

Cellular connection shows no errors in Log.

Mobile Connection is behind NAT, but that should be no problem, if my connection is done outward to my remote network?

So, I got it.

Testing with Telekom Sim Card, no problem with creating speedfusion VPN.
Switched to Vodafone and changed data port to 500 and it’s working now.

Seems Vodafone Germany is blocking port 4500.

1 Like