Max br1 pro 5G looking for latest firmware

I just received my Max br1 pro 5G. Firmware version is 8.1.2s109 build 4899. Where can I find latest firmware? I have hardware revision 1.


Hello Darren,

You can find it by searching under the Max category.

However, are you sure you have Hardware Revision 1? It only supports firmware up to 6.3.5


When I look on my router under Status/Device, I see Hardware revision 1 and firmware level of 8.1.2.s109 build 4899.

When I follow the link you sent, I do not see my Pepwave Max BR1 Pro 5G router.


Hello Darren,

It looks like this router doesn’t have any firmware upgrades.
The one you are currently is using is a special one.

Kinda of crazy that there isn’t a GA firmware for the BR1 Pro 5G don’t you think?

Shouldn’t something be added to the firmware page for it - even if it is just a link to the 8.1.2 special build?

BR1 Pro 5G was officially launched after 8.1.3 firmware. Hence, it is not included in 8.1.3 GA firmware. Its GA firmware will be available in 9.0.0.

Sorry for the inconvenience caused.

[Update 14 Jan 2021]
Firmware 8.2.0 Beta 2 is available for MAX BR1 Pro 5G model.

1 Like

ETA on the 9.0.0 build?

Hi. Any update on firmware for Max BR1 Pro 5G?

Looking for option to set my cellular network mode to generic as discussed here, seems to be available on most other devices but missing on the MAX BR1 Pro 5G on firmware 8.1.2s109 build 4899

Pro BR1 5G missing cell network type

Same here. I need this Generic setting.

Hi. @TK_Liew or Pep Team
Is there an eta or perhaps a beta we could test for you ?

Replying to my own posting here. I can confirm my dealer was able to get ahold of a firmware
fw-br1c-8.1.2s126-build4932 for me which has NETWORK TYPE in it that has allowed visible service to work on this device. I suspect this is in beta or alpha firmware as they are still investigating some strangeness I see on WIFI as WAN on 2.4GHZ.

my own personal notes:

= base build mine shipped to me with early Dec
= missing Network Type in cell settings
= WIFI as WAN 2.4 GHz can NOT connect
= speed on WIFI as WAN 5Ghz was >240MB (same as my WIFI router)

= fixed issue of WIFI as WAN 2.4 GHz can NOT connect but some strangeness persists
= still missing Network Type in cell settings
= slowed speed on WIFI as WAN 5Ghz is now 120MB (half of what it was before)

= fixed missing Network Type in cell settings, visible service now works when set to generic
= fixed issue of WIFI as WAN 2.4 GHz can NOT connect but some strangeness persists
= slowed speed on WIFI as WAN 5Ghz is now 120MB (half of what it was before on build4899)

1 Like

Thanks for putting this together. It’s disappointing that Peplink is not providing this level of detail somewhere for end-users.

I have over 10 customers who have this product and they are frustrated with bugs and instability, and that they cannot find public firmware.

Can we get an update on when a GA release will be available?

bummed to see the lack of beta firmware being noted here which is available to add in the GENERIC mode which then allows visible to work

What I am looking for today is an update on something I was just told by MobileMustHave about thier ATT plan with these devices.

Anyone sucessfully using ATT with the Max BR1 Pro 5G, if so what plan please

“What appears to be happening is that the modem chipset in the Br1 Pro 5G is reporting as “unknown” on the AT&T network and activation system. As a result, the network is “deauthorizing” the line. Our escalations team has verified if we manually authorize the line it will resume normal function until the modem is powered down or disconnected at which point the issue repeats itself.
This issue has been escalated to the carrier for additional investigation, but it’s possible it could take a few weeks for the carrier to resolve it.”

Which modem? I have not had a problem with AT&T or native VZW on the max transit 5g -BD. That has the Thales MV32 card.

is this the sierra?

Hi. Missed notification here, sorry.
hi Paul, yes the sierra.
happy to report that ATT is working great. Using apn Broadband getting great coverage and speed. Does seem one reseller that has special account and special apn is having their own issues, not related to hardware on ATT

Anyone else running on firmware 8.2.0 ? For me I was fairly stable on 8.1.2 build 4932 with good speed to VZ (via visible), ATT, and TMobile (via GVoice). Did still have strange issues with 2.4G and 5G wifi as WAN.

Few weeks ago I updated to 8.2.0 build 4961. After doing so I have now been seeing issues with cell connection backing off. (dashboard just says carrier name) all while parked and within great signal. Verified same behavior for SIMA and SIMB across VZ and ATT.

If I run a speed test generally the unit will ramp back up to 5G and give good speed but a few minutes later it will drop back. Resulting experience is often when loading a connection user will have to refresh thier browser a few times.

Cannot roll back to 8.1.2: to make matters worse I managed to “fill” my roll back slot on unit with 8.2.0 build versions (build 4950 and build 4961) which both have this issue. Doing a manul firmware upload of older 8.1.2 gives error of “must be 8.2.0 or higher”

Our vendor does have ticket open with PEP for the rollback issue

Are others seeing this backing off or cell disconnecting issue?

Any creative ideas on how to rollback to 8.1.2 ?

Have you tried inControl firmware management screens. I have downgraded firmware there previously.

I’ve seen this even in the initial firmware release for the BR1 Pro 5G. I’m also seeing it on the MBX Mini 5G. Peplink have remote access to one of my test units and are looking into it.

As far as I can tell, I’m still connected at 5G, but the display just shows the carrier name, and no other indication of the type of connection. If you click into the details while it is in that state, most of the time (not all) I have seen it still show being connected to a 5G NSA band and a few others. Sometimes it has dropped back to LTE.

@stevemitchell I can confirm that I also see that same behavior with Verizon.