MAX BR1 Pro 5G | Firmware 8.1.2 | "Visible" Network [Generic Verizon]

Unboxed a new unit today [new to Pepwave realm].

AT&T SIM from my phone works fine as a quick test.

VISIBLE SIM recognizes as a Verizon Network with Band values, however it never acquires an IP address. By default with Operator Settings at “Auto” the APN auto populates with vzwinternet. As documented, the APN must be manually set to vsblinternet - however the other requirement is to set the “Network Mode” to GENERIC - this Network Mode option doesn’t exist in the hardware/firmware combination…please advise, noting this VISIBLE SIM works fine in 2 different phones.

Thanks in advance -Derek

Hi Derek
Did you get visible working on your Max BR1 Pro 5G?

Think I am in similar situation here with Visible service not woring. I tried the APN as generic, vsblinternet, auto (comes in a vz). Also have tried the setting of lte only and auto.

edit: I am seeing that our units appear to be missing the option in the firmware !!

Pepwave MAX BR1 Pro 5G
on firmware
8.1.2s109 build 4899

here is a screenshot from a
BR1 LTE (MAX-BR1-LTE-US) with FW 8.0.2
where it clearly has this option

Any progress with this? I’m in the same situation. I cannot get internet to work on this using Visible.

It looks like we’re at an impasse. Peplink says there is nothing they can do and points to this being a product manufacturer problem. See image.

I’m having the same issue, but my card is not provisioned yet, although I activated it. (been told they check IMEI now, so you ned to clone if you want it to work.)

bummed to see the lack of beta firmware being noted here which is available to add in the GENERIC mode which then allows visible to work


FWIW: The Balance 20X (8.1.3 build 5060) stock modem does not offer a “generic” option , only auto, AT&T, Verizon and T-Mobile. I have observed Visible SIM cards working with “auto” as the carrier and the APN. Set to the Visible APN string. So the lack of a “generic” v. “auto” may be incidental to the problem.

Pure speculation, of course :slight_smile:



Any updates to getting Visible to work? TTL Fixes? Custom Firewall Tables? I tried Rooter but I didn’t like it.

Please upgrade the BR1 Pro 5G device using 8.2.0 RC1 and verify whether you still have the issue for the Cellular connection

Please open a support ticket to allow support team to check on this if you still have issue to get it connect.