MAX BR1 Pro 5G feedback / issues

I have been testing with the new MAX BR1 Pro 5G and have the following feedback / issues:

5G performance - comparing the BR1 Pro 5G to several other 5G products including the Netgear Nighthawk 5G, which has less band support, and worse antennas, the BR1 has less performance by 100-200Mbps in terms of download performance, and 10-20Mbps in terms of upload performance. Signal strengths look similar, as do the bands being used by the various products. While I have seen some great performance (~400Mbps down/40Mbps up) it is still quite a bit less than products half the cost. Are there known issues with the 8.1.2 firmware that came with the unit? Any plans to optimize this performance?

5G connection - about every other time that a cellular connection comes up, whether it be from a reboot or a swap between SIM A/B, the connection will come up as 4G/LTE-A and won’t flip to 5G for quite some time. Sometimes it happens within a minute or two, other times it will take a reboot or swap before it will again. I’m using 3x plans that are identical on a particular provider, such as Verizon, with 3 devices all in the same place with a very strong 5G signal. Is this a known bug with the connection side of things?

Connection type missing on dashboard - routinely I will only see the carrier that I am connected to, and not the connection type - LTE, LTE-A, or 5G. Sometimes it appears, other times it does not. Is this a known bug? Example below.

1 Like

Open a ticket.

I have 2 of these devices. One on ATT the other on VZW. My performance has actually improved with these devices. But the towers in my area (near coast Monterey Bay CA) are not high performance towers and the bottleneck is at the towers. Even still, I can pull 256Mb down (combined). Using a Max Transit Duo in the same spot would be lucky to hit 50Mb down (combined). 2x CAT18 devices ~100Mb down (combined).

VZW is the only 5G, no ATT “5G” here yet,… I do notice VZW oscillates between LTE & 5G. But my phone also on VZW does the same thing.

Next week I’ll be driving to Yosemite and will test performance at various places. Given this is in my camper van, I’m generally pretty happy to see 100Mb down / 20Mb up - anything more is bonus. When I ‘had’ tmobile, the only time I ever saw several hundred MB speedtest was on I-80 southwest of Sacremanto. Most times for me and my travels, tmobile was worse than ATT/VZW LTE or just non-existent. Consider your Tmobile service area to be “STELLAR”.

Does your BR1 5G have UI issues with “DELETE” red X in Outbound Policy? Like unable to delete rules after creation. Also cannot delete the default one. I manage all outbound policy via incontrol, but for temporary rules its pain to not be able to delete. so I disable them and wait for IC to refresh rules…

What firmware are you on with your MAX BR1 Pro 5G ?
We have been tracking / chatting about firmware for it over here
https://forum.peplink.com/t/Max-br1-pro-5G-looking-for-latest-firmware/617096d050e920458b1074be/

This was the first firmware shipped in November. It had the same problem you are citing in the other thread. I brought it up back in November but Peplink didn’t do anything with it. They’re apparently looking at it now…

Bump. I still have the same problem since I bought this pricey unit. Performance is 10Mbps if I am lucky on T-Mobile 5G but on my phone I get 250-350Mbps on T-Mobile. I updated my cellular modem FW, running 8.4.1 RC now and still no improvement. I also set my cellular interface to the FASTEST speed, a whole 100Mbps Full Duplex LOL. That is slower than the 5G service! What else is wrong with this thing?

Would be interesting to know your antenna setup, if your T-Mobile SIM in the router is on the same plan/setup as your phone, and how you’re testing throughput. I’ve not had any performance issues with T-Mobile for quite some time both on the BR1 and BR2. I just tested it a couple of minutes ago and am getting 150Mbps download speeds in a pretty congested and moderate signal area with T-Mobile…

No, the sim I am using is a T-Mobile prepaid SIM with a 2GB 5G plan. Nothing special, other than data only, being the purpose of the card. When I purchased it I told them it was for a router, data only. My antenna is the Peplink Mobility 42G antenna.

Kibitz: It may be that the difference you are seeing is this … Generally, the USA carriers accord pre-paid accounts a lower priority than post-paid. One of our test SIMs is the exact one you mention and we find the performance to be highly variable in a wide variety of equipment.

I did another test. I changed the primary WAN from Cellular to WiFi WAN which is served by my 1Gbps fiber connection on a UniFi network. I ran speed tests from different providers, pretty much the exact same results. 10-20Mbps down and up. If I run it on my MacBook Pro connected to that network we are talking about 300+ Mbps up and down with ease. If I run the speed test on my mobile phone, iPhone 11 and 13 Max Pro, same great results. The only difference is this Peplink/Wave unit. Something is definitely not right. It has factory defaults set, I even changed the cellular DNS to use Google’s 8.8.8.8 and no change.

Problem solved. Found this post on the Peplink forum with a new APN to manually try B2B.static and tada, speeds went through the roof. The Peplink forum post that saved me.

so what speeds are you now getting?

So far, 115Mbps down & 25.7Mbps up. I was only getting 10Mbps down and 1-2Mbps up.