MAX BR1 MK2 No Longer Connects to T-Mobile

I have a MAX BR1 MK2 in an RV. I have not used it in 3-4 months. I’m currently in the NC mountains now and it will not connect to cellular. Just states “Obtaining IP address”. Connects to campground Wi-Fi just fine. After two days of trouble shotting with T-Mobile technicians and a new SIM card it still will not connect. They said they can connect to the router. They concluded my router does not support band 7 & 12 and that is all T-Mobile uses in most areas since about July of this year.
Below it states I’m on Band 5

I find it hard to believe the MAX BR1 MK2 no longer works with T-Mobile.
Firmware is 8.2.1


OK so you disagree with their finding? “they concluded my router does not support band 7 & 12 and that is all T-Mobile uses in most areas since about July of this year” ??

Have you used any tools on a different device or looked up public cell tower info to see what bands it has/broadcasts for t-mobile?

I’m not sure what I think yet, just looking for advice here. I plan on taking the router with me to day to Boone to see if it works there. About 45 minutes away and I’m sure different towers.

I have not looked up tower information but will try to figure that out when I return back to the RV.

Went to Boone and it worked fine. So, I assume it has to do with the towers near the area I am camped at.
According to this coverage map from T-Mobile I am in an area that is supported by a Partner.

Do I have any options with this router? Would a different Pepwave work at in a partner area?

What partner? What bands? Does your plan allow roaming onto the partner?

Carolina West Wireless. Yes, it allows roaming. Odd thing is both phones work fine on the same towers.

What’s odd? What bands are the phones connecting on?

Odd that phones work and router will not connect. I don’t know how to see the iPhone connected bands. I looked but did not find them.

well you should figure that out. otherwise you won’t know what the issue is. its possible they are using different bands.

Well, I’ll tell you one way … If you have an iPhone type in 3001#12345# . Hit the icon in the upper right, then hit “serving cell info.” You’ll see the primary band on the next page. - Rick

I assume I do this as if making a call, right?
When I did that, I get a screen that states “Error performing request Unknown Error” Then the only option I get is Dismiss

@Mark_Spoon: Yes. This is what we use and have not have seen the results you report. Sorry, I can’t help further.

Thanks for trying

Mystery solved. Looking at settings once again and saw a roaming option. It states different countries but what the heck, let’s try it. BINGO!

Thanks to everyone that tried to help