Max BR1 and Google Fi

Greetings. When I purchased my class A RV it came with a pepwave br1. I put my SIM card in from Google fi after activation. It’s showing up on SIM card pay as SIM card detected and gives me a meid, ESN, in IMEI number. It shows up in network mode as AT&T / T-Mobile in auto. But I get no connectivity. Under APN I have h2g2. I’ve tried scanning under Network selection for Google fi but it doesn’t show up only T-Mobile Sprint AT&T Verizon and a 313 - 100. Whatever that is. But I still get no device detected under the wan connection status.
Any ideas? I live in this RV full time now and connectivity is extremely important to me right now. I plan on putting another service data Sim in at some point but haven’t decided on which one yet.
I’ve also upgraded the firmware to 7.1.2 build 3310.
Thanks for taking the time to answer my question
Bob

Welcome to the fourm.
I would make sure the sim card works in a phone before testing in the BR1.
Upgrade the br1 firmware, we are up to 8.1 RC2 now.

What area are you trying to use google fi in?
Make sure you enable roaming on google fi and that it’s getting a good signal.

2 Likes

Thanks Jonathan. My phone is a no sim card phone. Google sent it for data only. Not sure if it would work if I put it in my phone. I will update the firmware to 8. The unit hasn’t been used in a few years. I’m currently outside of Philadelphia near Reading. I have good phone connectivity but poor data. Using a cell booster to post this. Roaming is enabled.
hanks for your input.
Bob

What kind of antennas and boosters are you using.
What model of BR1 is it HW2, HW3, Mini?
What signal strength do you get.

The data only sim should work in your phone as data only.
Confirm that the fi sim is active in your app.

1 Like

There are 2 large antennas on the the top of coach.They look like ant ears. this system was set up by a previous owner who worked from the coach. its a max br1 LTE.
the booster is a webost drive 4gm. on my phone im getting 2 bars

ok thanks, update here when you test the sim in your phone and get the fw updated on your br1

1 Like

sim tested fine as a data only sim on my phone. Had some trouble getting the internal sim working again. But figured it out. almost downloaded the latest firmware. I tried connecting the BR1 directly to the antenna but the signal is to poor to pick up anything. Have to go thru the booster. I have 2, the weboost drive 4gm and a weboost drive 4GX. the signal goes thru them to 2 antenna ports on the BR1. I’ll post back when the firmware is upgraded.
Thanks

Ok upgraded to 8.1.0. Sim card detected in slot 1. MEID, ESN, and IMEI showing. Network mode showing as art/TMobile. Data roaming on. I have h2g2 in APN slot.
When I save and apply shows as no Sim detected in dashboard screen.

Can you post some screenshots?

1 Like

I’m attempting. Internet here is not good. I might be able to upload as a link. Working with a cell phone.


Try that please. Can’t drag them at this time to my laptop.

Try to set SIM Card to SIM A Only and Carrier Selection to Auto.
Try Network mode as ATT/T-mobile and then again as generic

Does the Cellular WAN not show on the Dashboard?
If that’s the case you may need to download a diagnostic file and submit a ticket to peplink.

1 Like

Tried all those. No luck. Called Google fi tech support. No luck.
Wonder if I’m in a bad area for this. Not great signal. But I am getting internet thru my Goole fi phone.

Call Google Fi and ask them what service you’re connected to on your phone T-Mobile Sprint or US Cellular the data only seems only work on T-Mobile so it’s possible that you have really bad T-Mobile coverage for the peplnk but okay coverage via one of the other carriers for your cell phone

1 Like

TMobile. How do I submit a support ticket to peplink?
Thinking about adding another 3rd party data sim. But would really like to get fi working on this since I have unlimited data plan.

I don’t know if this will be helpful, as I am on a max transit, but I was using google fi and for some odd reason the h2g2 apn never worked. It did work on the native t-mobile apn fast.t-mobile.com. Well it worked for me for about two days just fine then it dropped down to 2G speeds. I ended up getting my money back on that exchange. Good luck.