Max Adapter 5g to Max HD4 LTE Stuck on "Connecting"

I have purchased a Pepwave Max Adapter 5G to add 5g to our Max HD4 LTE. When I plug the Max Adapter into the HD4 via the usb port is stays hung on “connecting” it discovers the usb and the max adapter it just will not connect. I have restarted, reconnected the unit multiple times.

Do you have any suggestions how to get it to connect? or why it will not connect?

Can you try to load the 8.1.2s011 firmware, to see if the MAX Adapter 5G is able to get connected?

I tested our lab unit with a positive result. :wink:

1 Like


I have this same issue. I have tried downloading the above firmware but still no luck. I am now running the GM 8.1.3 and still having the same issue. Any help would be much appreciated.

Thank you,


Please refer this if you are using HD4.

Hello TK_Liew,

I did follow the instructions in that post and used firmware 8.1.2s011. My unit still will not work.

Thank you,


1 Like

I have a potential similar situation. I have a MAX Adapter 5G connected to an HD4 MBX and with AT&T it won’t ever go beyond “Connecting”. Verizon and T-Mobile connect fine. I’m in a very good signal area, and the same SIM can be used in the HD4 MBX on any modem and works fine.

Is there a firmware version for HD4 MBX that I can test?

Hi Team,

I have the same issue, are there any updates?

Best regards,