Maps not showing in Web Admin

I have a MAX Transit Duo connected to a poynting 7-in-1 Antenna. In the Web Admin, I see GPS coordinates, but no map, so I know the GPS is working. Remote Web Admin and inControl both show the map accurately and inControl shows the GPS data is streaming in with position updates. My firmware is up-to-date and the map used to show in the Web Admin in the past but doesn’t anymore. I’ve tried 3 different browsers with the same outcome.

Any thoughts on why it’s not showing up?


Hi @foretm
Is your firmware at 8.1.3? I only ask because this was an issue we ran into on 8.1.0 that was addressed in 8.1.1

If you do happen to be downlevel a little, I would start there.
Hopefully the firmware is all you’ll need, but if you’re already running the 8.1.3 firmware or the map still doesn’t populate once updated I’d suggest starting a ticket with Peplink to get it addressed. You can start that here: Peplink Ticketing System

When you start the ticket, you’ll want to be sure to have the router online with remote assistance turned on and also include a diagnostic report. You can find links to download the diagnostic report and to turn on remote assistance on the status tab of the router interface.

1 Like


Thanks, yes the firmware is 8.1.0, I just updated the inControl to schedule the firmware update tonight. I need the device right now during the business day. I appreciate the feedback, I will get the firmware updated to 8.1.3, it was working on the older firmware, and like I said it shows the coordinates on the web admin and the mapping on inControl and remote web admin are fine. I thought it may be a browser issue, but with three different ones, I had a feeling it was specific to the router.


Confirmed after the update to 8.1.3 the issue is resolved…