Management IP Address - 401 Invalid Privilege


#1

Hello,

I tried to setup the management IP Address to access the modems in bridge mode.

My setup is a Balance One Core with 5 WAN ports (6.3.1 build 2256)

WAN2 - modem address 172.16.12.2 --> management ip address 172.16.12.100, strange issue
WAN3 - modem address 172.16.13.2 --> management ip address 172.16.13.100, OK no problem
WAN4 - modem address 172.16.14.2 --> management ip address 172.16.14.100, OK no problem

so I did succeed in accessing the modems, but not on WAN2 (I haven’t tried WAN 1 yet). The following occurs:

  1. Go to 172.16.12.2 in browser --> official login of modem --> no problem
  2. fill in the username/password get this


You see that the URL is now incorporate with the Peplink /cgi-bin/MANGA. And my modem is not using such cgi-bin, for WAN3 it shows this:


Any ideas? (is there a difference/bug in WAN1&2 vs LAN1/2/3 that becomes WAN 3/4/5?)

Thanks,

ABM


#2

Possible to share the IP subnet below? If this is sensitive, please open ticket for us to take closer look.

  1. WAN1
  • IP address of PPPoE
  • Management IP subnet
  1. WAN2
  • IP address of PPPoE
  • Management IP subnet = 172.16.12.0/24
  1. WAN3
  • IP address of PPPoE
  • Management IP subnet = 172.16.13.0/24
  1. WAN4
  • IP address of PPPoE
  • Management IP subnet = 172.16.14.0/24
  1. LAN/VLAN IP subnet

  2. Static route (if available)

  3. IP subnet learned from PepVPN (if available)

  4. Remote Network of IPSec (if available)


#3

Is this what you meant?

  1. WAN1
  • IP address of PPPoE 217.146..
  • Management IP subnet
  1. WAN2
  • IP address of PPPoE 217.146..
  • Management IP subnet = 172.16.12.0/24
  1. WAN3
  • IP address of PPPoE 217.146..
  • Management IP subnet = 172.16.13.0/24
  1. WAN4
  • IP address of PPPoE 217.146..
  • Management IP subnet = 172.16.14.0/24
  1. LAN/VLAN IP subnet **192.168.0.1/23
    **

  2. Static route (if available) NO

  3. IP subnet learned from PepVPN (if available) NO

  4. Remote Network of IPSec (if available)** NO**

–> perhaps different topic and unrelated <—
Also odd, I see this in the dashboard (some inconsistency, WAN 3 has ADDITIONAL IP ADDRESS, I fill in the same settings?)




#4

This is strange. You have configured Additional IP instead of Management IP on WAN3 based on the screenshot. Can you provide the screenshot of the settings of WAN2, WAN3 and WAN4 (Network > WAN)?


#5

Well… sorry about that. I see where the additional IP comes from. (I added under
Additional Public IP Settings)

Sorry, but WAN2 still doesn’t work.


#6

Well… sorry about that. I see where the additional IP comes from. (I added under
Additional Public IP Settings)

Sorry, but WAN2 still doesn’t work.


#7

I suggest opening ticket for us to check further. No further idea without checking on the device.

Thank you.


#8

OK, ticket raised. thanks


#9

Hello,

Actually, since I removed the ip address in WAN 3 - Additional Public IP Settings, WAN2 allows me to login now.

so I tried the following:

  1. removed 172.16.13.2 to WAN3 as additional Public IP address
  2. WAN2, 172.16.12.2 works, no more 401 issues
  3. add 172.16.13.2 to WAN3 as additional Public IP address
  4. login into 172.16.12.2 (WAN2) --> no more 401 issues
  5. login into 172.16.13.2 --> peplink login, which should be correct setting after step 3
  6. removed 172.16.13.2 to WAN3 as additional Public IP address
  7. This screens appears now on 172.16.13.2


so I think I now know how to replicate the issue, does this looks like a ‘software’ issue?


#10

Hi amaravati,

I setup a test lab here and I cannot replicate this issue in the lab.

Would you mind if you can help us to try one thing ?

Everytime when you browse to the modem IP address, try to clear the browse cache first.

After you clear the browser cache, then browse to the modem IP address.

Let us know the test result again.

Thanks.

Regards,
Yaw Theng


#11

Dear Yew Theng,

Indeed it was the browsing data in Chrome (cached images & files). I am not sure, but perhaps you can adapt the peplink router pages to ‘not’ be cached those pages/js or whatever did that. It seems that it ‘screws’ up the login process, maybe because some scripts were similar to the modem I use (Zyxel VMG1312-B10A).

Thanks for helping and suggesting, sorry for the trouble.

Best wishes,

Narindo


#12

Hi amaravati,

Caching is actually done by the browser and this caching behavior cannot be controlled by Peplink devices.

For more information, you can refer to this article:


https://support.google.com/chrome/answer/95582?hl=en

Thanks.

Regards,
Yaw Theng